Apache Airflow Sqoop Provider: Airflow Sqoop Provider RCE Vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
Apache Airflow Sqoop Provider, versions before 4.0.0, is affected by a vulnerability that allows an attacker pass parameters with the connections, which makes it possible to implement RCE attacks via ‘sqoop import --connect’, obtain airflow server permissions, etc. The attacker needs to be logged in and have authorization (permissions) to create/edit connections. It is recommended to upgrade to a version that is not affected. This issue was reported independently by happyhacking-k, And Xie Jianming and LiuHui of Caiji Sec Team also reported it.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Airflow Sqoop Provider | before 4.0.0 | 4.0.0 | Patch available | CNA |
| — | apache-airflow-providers-apache-sqoop (PyPI) | before 4.0.0 | 4.0.0 | Patch available | GHSA-g3m9-pr5m-4cvp |
- Apache Airflow Sqoop Provider VendorApache Affected before 4.0.0 Fixed in 4.0.0 Patch available CNA
- apache-airflow-providers-apache-sqoop (PyPI) Vendor— Affected before 4.0.0 Fixed in 4.0.0 Patch available GHSA-g3m9-pr5m-4cvp
Remediation
- Fix · CNA Apache Airflow Sqoop Provider (Apache Software Foundation) Fixed in 4.0.0
- Fix · GHSA-g3m9-pr5m-4cvp apache-airflow-providers-apache-sqoop (PyPI) Fixed in 4.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-27604
- 2026-10-03 Alias added: GHSA-g3m9-pr5m-4cvp
References
Sources
- CVE-2023-27604 · CVE Program
- CVE-2023-27604 · NVD
- FIRST EPSS
- GHSA-g3m9-pr5m-4cvp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences