emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to Emacs Lisp code…
Priority HIGH 69CWE-94Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-94.
Summary
emacsclient-mail.desktop in Emacs 28.1 through 28.2 is vulnerable to Emacs Lisp code injections through a crafted mailto: URI with unescaped double-quote characters. It is fixed in 29.0.90.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00472 41st percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-27986
- 2026-10-03 Alias added: GHSA-whwp-m746-hx6w
References
Patch 3
More GNU Emacs vulnerabilities
- TI-2024-36089 In elisp-mode.el in GNU Emacs before 30.1, a user who chooses to invoke… CVSS 3.1HIGH 7.8
- TI-2022-23951 GNU Emacs through 28.2 allows attackers to execute commands via shell metacharacters in… CVSS 3.1CRITICAL 9.8
- TI-2024-26287 In Emacs before 29.4, org-link-expand-abbrev in lisp/ol.el expands a %(...) link abbrev… CVSS 3.1CRITICAL 9.8
- TI-2007-05829 Stack-based buffer overflow in emacs allows user-assisted attackers to cause a denial of… CVSS 2.0HIGH 10.0
- TI-2017-10588 GNU Emacs before 25.3 allows remote attackers to execute arbitrary code via email with… CVSS 3.0HIGH 8.8
- TI-2012-00034 Untrusted search path vulnerability in EDE in CEDET before 1.0.1, as used in GNU Emacs… CVSS 2.0HIGH 9.3
Sources
- CVE-2023-27986 · CVE Program
- CVE-2023-27986 · NVD
- FIRST EPSS
- GHSA-whwp-m746-hx6w · GitHub Advisory Database · CC BY 4.0
- CVE-2023-27986 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences