Command injection in discordrb
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
discordrb is an implementation of the Discord API using Ruby. In discordrb before commit `91e13043ffa` the `encoder.rb` file unsafely constructs a shell string using the file parameter, which can potentially leave clients of discordrb vulnerable to command injection. The library is not directly exploitable: the exploit requires that some client of the library calls the vulnerable method with user input. However, if unsafe input reaches the library method, then an attacker can execute arbitrary shell commands on the host machine. Full impact will depend on the permissions of the process running the `discordrb` library and will likely not be total system access. This issue has been addressed in code, but a new release of the `discordrb` gem has not been uploaded to rubygems. This issue is also tracked as `GHSL-2022-094`.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| shardlab | discordrb | up to 3.4.1 | — | No fix listed | CNA |
| — | discordrb (RubyGems) | before 3.4.3 | 3.4.3 | Patch available | GHSA-8832-4mm5-x2r6 |
- discordrb Vendorshardlab Affected up to 3.4.1 Fixed in — No fix listed CNA
- discordrb (RubyGems) Vendor— Affected before 3.4.3 Fixed in 3.4.3 Patch available GHSA-8832-4mm5-x2r6
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:discordrb_project:discordrb:*:*:*:*:*:ruby:*:* | before 2023-03-08 | Vulnerable | Discordrb Project |
- cpe:2.3:a:discordrb_project:discordrb:*:*:*:*:*:ruby:*:* Versions before 2023-03-08 Vulnerable ·Discordrb Project
Remediation
- Fix · GHSA-8832-4mm5-x2r6 discordrb (RubyGems) Fixed in 3.4.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-28102
- 2026-10-03 Alias added: GHSA-8832-4mm5-x2r6
References
Advisory 2
Sources
- CVE-2023-28102 · CVE Program
- CVE-2023-28102 · NVD
- FIRST EPSS
- GHSA-8832-4mm5-x2r6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences