Discourse's SSRF protection missing for some FastImage requests
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Discourse is an open-source discussion platform. Prior to version 3.1.0.beta3 of the `beta` and `tests-passed` branches, some user provided URLs were being passed to FastImage without SSRF protection. Insufficient protections could enable attackers to trigger outbound network connections from the Discourse server to private IP addresses. This affects any site running the `tests-passed` or `beta` branches versions 3.1.0.beta2 and prior. This issue is patched in version 3.1.0.beta3 of the `beta` and `tests-passed` branches. There are no known workarounds.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| discourse | discourse | beta < 3.1.0.beta3; tests-passed < 3.1.0.beta3 | — | No fix listed | CNA |
- discourse Vendordiscourse Affected beta < 3.1.0.beta3; tests-passed < 3.1.0.beta3 Fixed in — No fix listed CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:discourse:discourse:*:*:*:*:beta:*:*:* | before 3.1.0 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:*:*:*:*:stable:*:*:* | up to 3.1.0 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:3.1.0:beta1:*:*:beta:*:*:* | 3.1.0 beta1 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:3.1.0:beta2:*:*:beta:*:*:* | 3.1.0 beta2 | Vulnerable | discourse |
- cpe:2.3:a:discourse:discourse:*:*:*:*:beta:*:*:* Versions before 3.1.0 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:*:*:*:*:stable:*:*:* Versions up to 3.1.0 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:3.1.0:beta1:*:*:beta:*:*:* Versions 3.1.0 beta1 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:3.1.0:beta2:*:*:beta:*:*:* Versions 3.1.0 beta2 Vulnerable ·discourse
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-28112
References
More Discourse vulnerabilities
- TI-2021-19656 Denial of Service in discourse CVSS 3.1MEDIUM 6.8
- TI-2024-36150 Potential Backup file leaked via Nginx in Discourse CVSS 3.1HIGH 7.5
- TI-2021-18002 RCE via malicious SNS subscription payload CVSS 3.1CRITICAL 10.0
- TI-2026-24651 Discourse: Open redirect via `sso_destination_url` cookie in `enter` CVSS 4.0MEDIUM 5.1
- TI-2026-22278 Discourse leaks private topic title and post excerpt via user action API endpoint CVSS 4.0HIGH 8.7
- TI-2023-24152 Unauthenticated access to new private chat messages in Discourse CVSS 3.1HIGH 7.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences