russh may use insecure Diffie-Hellman keys
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-347.
Summary
russh is a Rust SSH client and server library. Starting in version 0.34.0 and prior to versions 0.36.2 and 0.37.1, Diffie-Hellman key validation is insufficient, which can lead to insecure shared secrets and therefore breaks confidentiality. Connections between a russh client and server or those of a russh peer with some other misbehaving peer are most likely to be problematic. These may vulnerable to eavesdropping. Most other implementations reject such keys, so this is mainly an interoperability issue in such a case. This issue is fixed in versions 0.36.2 and 0.37.1
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| warp-tech | russh | 0.34.0 and later; 0.36.2 to before 0.36.2; 0.37.0 and later; 0.37.1 to before 0.37.1 | 0.36.2, 0.37.1 | Patch available | CNA |
| — | russh (crates.io) | before 0.36.2 | 0.36.2 | Patch available | GHSA-cqvm-j2r2-hwpg |
| — | russh (crates.io) | 0.37.0 to before 0.37.1 | 0.37.1 | Patch available | GHSA-cqvm-j2r2-hwpg |
- russh Vendorwarp-tech Affected 0.34.0 and later; 0.36.2 to before 0.36.2; 0.37.0 and later; 0.37.1 to before 0.37.1 Fixed in 0.36.2, 0.37.1 Patch available CNA
- russh (crates.io) Vendor— Affected before 0.36.2 Fixed in 0.36.2 Patch available GHSA-cqvm-j2r2-hwpg
- russh (crates.io) Vendor— Affected 0.37.0 to before 0.37.1 Fixed in 0.37.1 Patch available GHSA-cqvm-j2r2-hwpg
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:russh_project:russh:*:*:*:*:*:rust:*:* | 0.34.0 to before 0.36.2 | Vulnerable | Russh Project |
| cpe:2.3:a:russh_project:russh:0.37.0:-:*:*:*:rust:*:* | 0.37.0 | Vulnerable | Russh Project |
| cpe:2.3:a:russh_project:russh:0.37.0:beta1:*:*:*:rust:*:* | 0.37.0 beta1 | Vulnerable | Russh Project |
- cpe:2.3:a:russh_project:russh:*:*:*:*:*:rust:*:* Versions 0.34.0 to before 0.36.2 Vulnerable ·Russh Project
- cpe:2.3:a:russh_project:russh:0.37.0:-:*:*:*:rust:*:* Versions 0.37.0 Vulnerable ·Russh Project
- cpe:2.3:a:russh_project:russh:0.37.0:beta1:*:*:*:rust:*:* Versions 0.37.0 beta1 Vulnerable ·Russh Project
Remediation
- Fix · CNA russh (warp-tech) Fixed in 0.36.2, 0.37.1
- Fix · GHSA-cqvm-j2r2-hwpg russh (crates.io) Fixed in 0.36.2 Advisory →
- Fix · GHSA-cqvm-j2r2-hwpg russh (crates.io) Fixed in 0.37.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-28113
- 2026-10-03 Alias added: GHSA-cqvm-j2r2-hwpg
- 2026-10-24 EPSS moved to the 50th–90th percentile
References
Other 6
- https://github.com/warp-tech/russh/blob/master/russh/src/kex/dh/groups.rs#L72-L76
- https://github.com/warp-tech/russh/blob/master/russh/src/kex/dh/groups.rs#L78-L81
- https://github.com/warp-tech/russh/releases/tag/v0.36.2
- https://github.com/warp-tech/russh/releases/tag/v0.37.1
- https://github.com/warp-tech/russh/commit/45d2d82930bf4a675bd57abfafec8fe4065befcd
- https://github.com/warp-tech/russh
More warp-tech vulnerabilities
- TI-2023-18898 User login confusion with SSO in warpgate CVSS 3.1HIGH 8.8
- TI-2026-30510 Russh: Pre-auth DoS via unbounded allocation in keyboard-interactive auth CVSS 3.1HIGH 7.5
- TI-2024-29059 Russh has an OOM Denial of Service due to allocation of untrusted amount CVSS 3.1HIGH 7.5
- TI-2026-45163 Improper authorization in warp-tech warpgate CVSS 3.1HIGH 7.7
- TI-2026-32313 Warpgate: SSO CSRF -- State Token Not Validated on Return CVSS 3.1MEDIUM 6.5
- TI-2025-34558 Russh is missing an overflow check during channel windows adjust CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-28113 · CVE Program
- CVE-2023-28113 · NVD
- FIRST EPSS
- GHSA-cqvm-j2r2-hwpg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences