Insufficiently protected credentials in Expo.io Expo AuthSession module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
A vulnerability in the expo.io framework allows an attacker to take over accounts and steal credentials on an application/website that configured the "Expo AuthSession Redirect Proxy" for social sign-in. This can be achieved once a victim clicks a malicious link. The link itself may be sent to the victim in various ways (including email, text message, an attacker-controlled website, etc).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Expo.io | Expo AuthSession module | all versions | — | No fix listed | CNA |
| — | expo (npm) | before 48.0.0 | 48.0.0 | Patch available | GHSA-wr5g-q49g-548w |
- Expo AuthSession module VendorExpo.io Affected all versions Fixed in — No fix listed CNA
- expo (npm) Vendor— Affected before 48.0.0 Fixed in 48.0.0 Patch available GHSA-wr5g-q49g-548w
Remediation
- Fix · GHSA-wr5g-q49g-548w expo (npm) Fixed in 48.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-28131
- 2026-10-03 Alias added: GHSA-wr5g-q49g-548w
References
Advisory 2
Sources
- CVE-2023-28131 · CVE Program
- CVE-2023-28131 · NVD
- FIRST EPSS
- GHSA-wr5g-q49g-548w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences