Non-interactive Tailscale SSH sessions on FreeBSD may use the effective group ID of the tailscaled process
Key facts
- Attack vector
- Adjacent network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-269.
Summary
Tailscale is software for using Wireguard and multi-factor authentication (MFA). A vulnerability identified in the implementation of Tailscale SSH starting in version 1.34.0 and prior to prior to 1.38.2 in FreeBSD allows commands to be run with a higher privilege group ID than that specified in Tailscale SSH access rules. A difference in the behavior of the FreeBSD `setgroups` system call from POSIX meant that the Tailscale client running on a FreeBSD-based operating system did not appropriately restrict groups on the host when using Tailscale SSH. When accessing a FreeBSD host over Tailscale SSH, the egid of the tailscaled process was used instead of that of the user specified in Tailscale SSH access rules. Tailscale SSH commands may have been run with a higher privilege group ID than that specified in Tailscale SSH access rules if they met all of the following criteria: the destination node was a FreeBSD device with Tailscale SSH enabled; Tailscale SSH access rules permitted access for non-root users; and a non-interactive SSH session was used. Affected users should upgrade to version 1.38.2 to remediate the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tailscale | tailscale | 1.34.0 to before 1.38.2 | 1.38.2 | Patch available | CNA |
| — | tailscale.com (Go) | 1.34.0 to before 1.38.2 | 1.38.2 | Patch available | GHSA-vfgq-g5x8-g595 |
- tailscale Vendortailscale Affected 1.34.0 to before 1.38.2 Fixed in 1.38.2 Patch available CNA
- tailscale.com (Go) Vendor— Affected 1.34.0 to before 1.38.2 Fixed in 1.38.2 Patch available GHSA-vfgq-g5x8-g595
Remediation
- Fix · CNA tailscale (tailscale) Fixed in 1.38.2
- Fix · GHSA-vfgq-g5x8-g595 tailscale.com (Go) Fixed in 1.38.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-28436
- 2026-10-03 Alias added: GHSA-vfgq-g5x8-g595
References
Patch 2
Advisory 3
More Tailscale vulnerabilities
- TI-2022-20265 Tailscale Windows daemon is vulnerable to RCE via CSRF CVSS 3.1CRITICAL 9.6
- TI-2022-20266 Tailscale daemon is vulnerable to information disclosure via CSRF CVSS 3.1HIGH 8.8
Sources
- CVE-2023-28436 · CVE Program
- CVE-2023-28436 · NVD
- FIRST EPSS
- GHSA-vfgq-g5x8-g595 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences