Geoserver for GeoNode sensitive information leak
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-200.
Summary
GeoNode is an open source platform that facilitates the creation, sharing, and collaborative use of geospatial data. Prior to versions 2.20.6, 2.19.6, and 2.18.7, anonymous users can obtain sensitive information about GeoNode configurations from the response of the `/geoserver/rest/about/status` Geoserver REST API endpoint. The Geoserver endpoint is secured by default, but the configuration of Geoserver for GeoNode opens a list of REST endpoints to support some of its public-facing services. The vulnerability impacts both GeoNode 3 and GeoNode 4 instances. Geoserver security configuration is provided by `geoserver-geonode-ext`. A patch for 2.20.7 has been released which blocks access to the affected endpoint. The patch has been backported to branches 2.20.6, 2.19.7, 2.19.6, and 2.18.7. All the published artifacts and Docker images have been updated accordingly. A more advanced patch has been applied to the master and development versions, which require some changes to GeoNode code. They will be available with the next 4.1.0 release. The patched configuration only has an effect on new deployments. For existing setups, the patch must be applied manually inside the Geoserver data directory. The patched file must replace the existing `<geoserver_datadir>/security/rest.properties` file.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GeoNode | geonode | 2.20.0 to before 2.20.6; 2.19.0 to before 2.19.6; before 2.18.7 | 2.20.6, 2.19.6, 2.18.7 | Patch available | CNA |
- geonode VendorGeoNode Affected 2.20.0 to before 2.20.6; 2.19.0 to before 2.19.6; before 2.18.7 Fixed in 2.20.6, 2.19.6, 2.18.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:geosolutionsgroup:geonode:*:*:*:*:*:*:*:* | before 2.18.7; 2.19.0 to before 2.19.6; 2.20.0 to before 2.20.6 | Vulnerable | GeoNode |
- cpe:2.3:a:geosolutionsgroup:geonode:*:*:*:*:*:*:*:* Versions before 2.18.7; 2.19.0 to before 2.19.6; 2.20.0 to before 2.20.6 Vulnerable ·GeoNode
Remediation
- Fix · CNA geonode (GeoNode) Fixed in 2.20.6, 2.19.6, 2.18.7
Timeline
- 2026-10-02 Threatist record created from CVE-2023-28442
- 2026-10-23 EPSS moved to the 50th–90th percentile
References
More Geonode vulnerabilities
- TI-2023-22605 GeoNode SSRF Bypass to return internal host data CVSS 3.1HIGH 7.5
- TI-2023-11277 XML External Entity (XXE) injection in GeoServer style upload functionality CVSS 3.1MEDIUM 6.5
- TI-2023-20907 Geonode Server Side Request Forgery vulnerability CVSS 3.1HIGH 7.5
- TI-2024-17952 GeoNode stored XSS to full account takeover CVSS 3.1MEDIUM 6.1
- TI-2026-28791 GeoNode SSRF via Service Registration CVSS 4.0MEDIUM 5.3
- TI-2026-28790 GeoNode < 4.4.5, 5.0.2 SSRF via Document Upload CVSS 4.0MEDIUM 5.3
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences