`authority-regex` returns the wrong authority in lambdaisland/uri
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-601.
Summary
lambdaisland/uri is a pure Clojure/ClojureScript URI library. In versions prior to 1.14.120 `authority-regex` allows an attacker to send malicious URLs to be parsed by the `lambdaisland/uri` and return the wrong authority. This issue is similar to but distinct from CVE-2020-8910. The regex in question doesn't handle the backslash (`\`) character in the username correctly, leading to a wrong output. ex. a payload of `https://example.com\\@google.com` would return that the host is `google.com`, but the correct host should be `example.com`. Given that the library returns the wrong authority this may be abused to bypass host restrictions depending on how the library is used in an application. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| lambdaisland | uri | before 1.14.120 | 1.14.120 | Patch available | CNA |
| — | lambdaisland:uri (Maven) | before 1.14.120 | 1.14.120 | Patch available | GHSA-cp4w-6x4w-v2h5 |
- uri Vendorlambdaisland Affected before 1.14.120 Fixed in 1.14.120 Patch available CNA
- lambdaisland:uri (Maven) Vendor— Affected before 1.14.120 Fixed in 1.14.120 Patch available GHSA-cp4w-6x4w-v2h5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:lambdaisland:uri:*:*:*:*:*:*:*:* | before 1.14.120 | Vulnerable | lambdaisland |
- cpe:2.3:a:lambdaisland:uri:*:*:*:*:*:*:*:* Versions before 1.14.120 Vulnerable ·lambdaisland
Remediation
- Fix · CNA uri (lambdaisland) Fixed in 1.14.120
- Fix · GHSA-cp4w-6x4w-v2h5 lambdaisland:uri (Maven) Fixed in 1.14.120 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-28628
- 2026-10-03 Alias added: GHSA-cp4w-6x4w-v2h5
References
Other 4
- https://github.com/google/closure-library/blob/0e567abedb058e9b194a40cfa3ad4c507653bccf/closure/goog/uri/utils.js#L189
- https://github.com/lambdaisland/uri
- https://github.com/lambdaisland/uri/blob/d3355fcd3e235238f4dcd37be97787a84e580072/src/lambdaisland/uri.cljc#L9
- https://github.com/lambdaisland/uri/releases/tag/v1.14.120
Sources
- CVE-2023-28628 · CVE Program
- CVE-2023-28628 · NVD
- FIRST EPSS
- GHSA-cp4w-6x4w-v2h5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences