GLPI vulnerable to Privilege Escalation from Technician to Super-Admin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-285.
Summary
GLPI is a free asset and IT management software package. Starting in version 0.83 and prior to versions 9.5.13 and 10.0.7, a user who has the Technician profile could see and generate a Personal token for a Super-Admin. Using such token it is possible to negotiate a GLPI session and hijack the Super-Admin account, resulting in a Privilege Escalation. Versions 9.5.13 and 10.0.7 contain a patch for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| glpi-project | glpi | 0.83 to before 9.5.13; 10.0.0 to before 10.0.7 | 9.5.13, 10.0.7 | Patch available | CNA |
- glpi Vendorglpi-project Affected 0.83 to before 9.5.13; 10.0.0 to before 10.0.7 Fixed in 9.5.13, 10.0.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:* | 0.83 to before 9.5.13; 10.0.0 to before 10.0.7 | Vulnerable | glpi-project |
- cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:* Versions 0.83 to before 9.5.13; 10.0.0 to before 10.0.7 Vulnerable ·glpi-project
Remediation
- Fix · CNA glpi (glpi-project) Fixed in 9.5.13, 10.0.7
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-28634
References
More glpi-project Glpi vulnerabilities
- TI-2022-16341 /vendor/htmlawed/htmlawed/htmLawedTest.php in the htmlawed module for GLPI through 10.0.2 allows PHP code injection. KEVCVSS 3.1CRITICAL 9.8
- TI-2025-18516 GLPI allows unauthenticated SQL injection through the inventory endpoint CVSS 3.1CRITICAL 9.8
- TI-2023-25210 GLPI SQL injection through inventory agent request CVSS 3.1CRITICAL 9.8
- TI-2023-17986 GLPI vulnerable to SQL injection via inventory agent request CVSS 3.1CRITICAL 9.8
- TI-2022-13106 SQL injection on login page in GLPI CVSS 3.1CRITICAL 9.8
- TI-2023-18602 GLPI vulnerable to SQL injection through Computer Virtual Machine information CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-28634 · CVE Program
- CVE-2023-28634 · NVD
- FIRST EPSS
- CVE-2023-28634 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences