Read the docs
TI-2023-13158 Aliases CVE-2023-28639

GLPI vulnerable to reflected Cross-site Scripting in search pages

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

GLPI is a free asset and IT management software package. Starting in version 0.85 and prior to versions 9.5.13 and 10.0.7, a malicious link can be crafted by an unauthenticated user. It will be able to exploit a reflected XSS in case any authenticated user opens the crafted link. This issue is fixed in versions 9.5.13 and 10.0.7.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00605 49th percentileScored 2026-11-07
Fix Fixed glpi (glpi): 9.5.13, 10.0.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
glpi-projectglpi0.85 and later; 9.5.13 to before 9.5.13; 10.0.0 and later; 10.0.7 to before 10.0.79.5.13, 10.0.7Patch availableCNA
  • glpi Vendorglpi-project Affected 0.85 and later; 9.5.13 to before 9.5.13; 10.0.0 and later; 10.0.7 to before 10.0.7 Fixed in 9.5.13, 10.0.7 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*0.85 to before 9.5.13; 10.0.0 to before 10.0.7Vulnerableglpi-project
  • cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:* Versions 0.85 to before 9.5.13; 10.0.0 to before 10.0.7 Vulnerable ·glpi-project

Remediation

  • Fix · CNA glpi (glpi) Fixed in 9.5.13, 10.0.7

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-28639

References

  • TI-2022-16341 /vendor/htmlawed/htmlawed/htmLawedTest.php in the htmlawed module for GLPI through 10.0.2 allows PHP code injection. KEVCVSS 3.1CRITICAL 9.8
  • TI-2025-18516 GLPI allows unauthenticated SQL injection through the inventory endpoint CVSS 3.1CRITICAL 9.8
  • TI-2023-25210 GLPI SQL injection through inventory agent request CVSS 3.1CRITICAL 9.8
  • TI-2023-17986 GLPI vulnerable to SQL injection via inventory agent request CVSS 3.1CRITICAL 9.8
  • TI-2022-13106 SQL injection on login page in GLPI CVSS 3.1CRITICAL 9.8
  • TI-2023-18602 GLPI vulnerable to SQL injection through Computer Virtual Machine information CVSS 3.1CRITICAL 9.8
See all 187 →

Sources