Apache InLong: Insufficient Session Expiration in InLong
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-613.
Summary
Insufficient Session Expiration vulnerability in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.6.0. An old session can be used by an attacker even after the user has been deleted or the password has been changed. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 , https://github.com/apache/inlong/pull/7884 https://github.com/apache/inlong/pull/7884 to solve it.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache InLong | 1.4.0 – 1.6.0 | — | No fix listed | CNA |
| — | org.apache.inlong:manager-pojo (Maven) | 1.4.0 to before 1.7.0 | 1.7.0 | Patch available | GHSA-757p-7hp5-pqmr |
| — | org.apache.inlong:manager-dao (Maven) | 1.4.0 to before 1.7.0 | 1.7.0 | Patch available | GHSA-757p-7hp5-pqmr |
| — | org.apache.inlong:manager-web (Maven) | 1.4.0 to before 1.7.0 | 1.7.0 | Patch available | GHSA-757p-7hp5-pqmr |
| — | org.apache.inlong:manager-service (Maven) | 1.4.0 to before 1.7.0 | 1.7.0 | Patch available | GHSA-757p-7hp5-pqmr |
- Apache InLong VendorApache Affected 1.4.0 – 1.6.0 Fixed in — No fix listed CNA
- org.apache.inlong:manager-pojo (Maven) Vendor— Affected 1.4.0 to before 1.7.0 Fixed in 1.7.0 Patch available GHSA-757p-7hp5-pqmr
- org.apache.inlong:manager-dao (Maven) Vendor— Affected 1.4.0 to before 1.7.0 Fixed in 1.7.0 Patch available GHSA-757p-7hp5-pqmr
- org.apache.inlong:manager-web (Maven) Vendor— Affected 1.4.0 to before 1.7.0 Fixed in 1.7.0 Patch available GHSA-757p-7hp5-pqmr
- org.apache.inlong:manager-service (Maven) Vendor— Affected 1.4.0 to before 1.7.0 Fixed in 1.7.0 Patch available GHSA-757p-7hp5-pqmr
Remediation
- Fix · GHSA-757p-7hp5-pqmr org.apache.inlong:manager-pojo (Maven) Fixed in 1.7.0 Advisory →
- Fix · GHSA-757p-7hp5-pqmr org.apache.inlong:manager-dao (Maven) Fixed in 1.7.0 Advisory →
- Fix · GHSA-757p-7hp5-pqmr org.apache.inlong:manager-web (Maven) Fixed in 1.7.0 Advisory →
- Fix · GHSA-757p-7hp5-pqmr org.apache.inlong:manager-service (Maven) Fixed in 1.7.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-31065
- 2026-10-03 Alias added: GHSA-757p-7hp5-pqmr
References
More Apache Inlong vulnerabilities
- TI-2023-28411 Apache InLong: Remote Code Execution vulnerability in Apache InLong Manager CVSS 3.1CRITICAL 9.8
- TI-2023-23393 Apache InLong: Jdbc Connection Security Bypass in InLong CVSS 3.1CRITICAL 9.8
- TI-2023-17558 Apache InLong: SQL injection in audit endpoint CVSS 3.1CRITICAL 9.8
- TI-2023-10470 Apache InLong: Jdbc Connection Security Bypass CVSS 3.1CRITICAL 9.8
- TI-2023-14823 Apache InLong: Weak Password Implementation in InLong CVSS 3.1CRITICAL 9.8
- TI-2023-14790 Apache InLong: Privilege escalation vulnerability for InLong CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-31065 · CVE Program
- CVE-2023-31065 · NVD
- FIRST EPSS
- GHSA-757p-7hp5-pqmr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences