A dependency confusion in pipreqs v0.3.0 to v0.4.11 allows attackers to execute arbitrary…
Priority HIGH 82CWE-427Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-427.
Summary
A dependency confusion in pipreqs v0.3.0 to v0.4.11 allows attackers to execute arbitrary code via uploading a crafted PyPI package to the chosen repository server.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01177 67th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed pipreqs (PyPI): 0.4.12
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pipreqs (PyPI) | 0.3.0 to before 0.4.12 | 0.4.12 | Patch available | GHSA-v4f4-23wc-99mh |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pipreqs (PyPI) Vendor— Affected 0.3.0 to before 0.4.12 Fixed in 0.4.12 Patch available GHSA-v4f4-23wc-99mh
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pipreqs_project:pipreqs:*:*:*:*:*:python:*:* | 0.3.0 – 0.4.11 | Vulnerable | Pipreqs Project |
- cpe:2.3:a:pipreqs_project:pipreqs:*:*:*:*:*:python:*:* Versions 0.3.0 – 0.4.11 Vulnerable ·Pipreqs Project
Remediation
- Fix · GHSA-v4f4-23wc-99mh pipreqs (PyPI) Fixed in 0.4.12 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-31543
- 2026-10-03 Alias added: GHSA-v4f4-23wc-99mh
References
Exploit 2
Sources
- CVE-2023-31543 · CVE Program
- CVE-2023-31543 · NVD
- FIRST EPSS
- GHSA-v4f4-23wc-99mh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences