Resource allocation without limits in SUSE k3s
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-770.
Summary
An Allocation of Resources Without Limits or Throttling vulnerability in SUSE k3s allows attackers with access to K3s servers' apiserver/supervisor port (TCP 6443) cause denial of service. This issue affects k3s: from v1.24.0 before v1.24.17+k3s1, from v1.25.0 before v1.25.13+k3s1, from v1.26.0 before v1.26.8+k3s1, from sev1.27.0 before v1.27.5+k3s1, from v1.28.0 before v1.28.1+k3s1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | k3s | v1.24.0 to before v1.24.17+k3s1; v1.25.0 to before v1.25.13+k3s1; v1.26.0 to before v1.26.8+k3s1; sev1.27.0 to before v1.27.5+k3s1; v1.28.0 to before v1.28.1+k3s1 | v1.24.17+k3s1, v1.25.13+k3s1, v1.26.8+k3s1, v1.27.5+k3s1, v1.28.1+k3s1 | Patch available | CNA |
| — | github.com/k3s-io/k3s (Go) | before 1.24.17 | 1.24.17 | Patch available | GHSA-m4hf-6vgr-75r2 |
| — | github.com/k3s-io/k3s (Go) | 1.25.0 to before 1.25.13 | 1.25.13 | Patch available | GHSA-m4hf-6vgr-75r2 |
| — | github.com/k3s-io/k3s (Go) | 1.26.0 to before 1.26.8 | 1.26.8 | Patch available | GHSA-m4hf-6vgr-75r2 |
| — | github.com/k3s-io/k3s (Go) | 1.27.0 to before 1.27.5 | 1.27.5 | Patch available | GHSA-m4hf-6vgr-75r2 |
| — | github.com/k3s-io/k3s (Go) | 1.28.0 to before 1.28.1 | 1.28.1 | Patch available | GHSA-m4hf-6vgr-75r2 |
- k3s VendorSUSE Affected v1.24.0 to before v1.24.17+k3s1; v1.25.0 to before v1.25.13+k3s1; v1.26.0 to before v1.26.8+k3s1; sev1.27.0 to before v1.27.5+k3s1; v1.28.0 to before v1.28.1+k3s1 Fixed in v1.24.17+k3s1, v1.25.13+k3s1, v1.26.8+k3s1, v1.27.5+k3s1, v1.28.1+k3s1 Patch available CNA
- github.com/k3s-io/k3s (Go) Vendor— Affected before 1.24.17 Fixed in 1.24.17 Patch available GHSA-m4hf-6vgr-75r2
- github.com/k3s-io/k3s (Go) Vendor— Affected 1.25.0 to before 1.25.13 Fixed in 1.25.13 Patch available GHSA-m4hf-6vgr-75r2
- github.com/k3s-io/k3s (Go) Vendor— Affected 1.26.0 to before 1.26.8 Fixed in 1.26.8 Patch available GHSA-m4hf-6vgr-75r2
- github.com/k3s-io/k3s (Go) Vendor— Affected 1.27.0 to before 1.27.5 Fixed in 1.27.5 Patch available GHSA-m4hf-6vgr-75r2
- github.com/k3s-io/k3s (Go) Vendor— Affected 1.28.0 to before 1.28.1 Fixed in 1.28.1 Patch available GHSA-m4hf-6vgr-75r2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:k3s:k3s:*:*:*:*:*:*:*:* | 1.24.0 to before 1.24.17\+k3s1; 1.25.0 to before 1.25.13\+k3s1; 1.26.0 to before 1.26.8\+k3s1; 1.27.0 to before 1.27.5\+k3s1; 1.28.0 to before 1.28.1\+k3s1 | Vulnerable | K3s |
- cpe:2.3:a:k3s:k3s:*:*:*:*:*:*:*:* Versions 1.24.0 to before 1.24.17\+k3s1; 1.25.0 to before 1.25.13\+k3s1; 1.26.0 to before 1.26.8\+k3s1; 1.27.0 to before 1.27.5\+k3s1; 1.28.0 to before 1.28.1\+k3s1 Vulnerable ·K3s
Remediation
- Fix · CNA k3s (SUSE) Fixed in v1.24.17+k3s1, v1.25.13+k3s1, v1.26.8+k3s1, v1.27.5+k3s1, v1.28.1+k3s1
- Fix · GHSA-m4hf-6vgr-75r2 github.com/k3s-io/k3s (Go) Fixed in 1.24.17 Advisory →
- Fix · GHSA-m4hf-6vgr-75r2 github.com/k3s-io/k3s (Go) Fixed in 1.25.13 Advisory →
- Fix · GHSA-m4hf-6vgr-75r2 github.com/k3s-io/k3s (Go) Fixed in 1.26.8 Advisory →
- Fix · GHSA-m4hf-6vgr-75r2 github.com/k3s-io/k3s (Go) Fixed in 1.27.5 Advisory →
- Fix · GHSA-m4hf-6vgr-75r2 github.com/k3s-io/k3s (Go) Fixed in 1.28.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32187
- 2026-10-03 Alias added: GHSA-m4hf-6vgr-75r2
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-32187 · CVE Program
- CVE-2023-32187 · NVD
- FIRST EPSS
- GHSA-m4hf-6vgr-75r2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences