rke's credentials are stored in the RKE1 Cluster state ConfigMap
Priority MEDIUM 44CWE-922Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-922.
Summary
When RKE provisions a cluster, it stores the cluster state in a configmap called `full-cluster-state` inside the `kube-system` namespace of the cluster itself. The information available in there allows non-admin users to escalate to admin.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0066 51st percentileScored 2026-11-07
Fix Fixed rke (SUSE): 1.4.19, 1.5.10github.com/rancher/rke (Go): 1.4.19, 1.5.10
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | rke | 1.4.18 to before 1.4.19; 1.5.9 to before 1.5.10 | 1.4.19, 1.5.10 | Patch available | CNA |
| — | github.com/rancher/rke (Go) | 1.4.18 to before 1.4.19 | 1.4.19 | Patch available | GHSA-6gr4-52w6-vmqx |
| — | github.com/rancher/rke (Go) | 1.5.9 to before 1.5.10 | 1.5.10 | Patch available | GHSA-6gr4-52w6-vmqx |
- rke VendorSUSE Affected 1.4.18 to before 1.4.19; 1.5.9 to before 1.5.10 Fixed in 1.4.19, 1.5.10 Patch available CNA
- github.com/rancher/rke (Go) Vendor— Affected 1.4.18 to before 1.4.19 Fixed in 1.4.19 Patch available GHSA-6gr4-52w6-vmqx
- github.com/rancher/rke (Go) Vendor— Affected 1.5.9 to before 1.5.10 Fixed in 1.5.10 Patch available GHSA-6gr4-52w6-vmqx
Remediation
- Fix · CNA rke (SUSE) Fixed in 1.4.19, 1.5.10
- Fix · GHSA-6gr4-52w6-vmqx github.com/rancher/rke (Go) Fixed in 1.4.19 Advisory →
- Fix · GHSA-6gr4-52w6-vmqx github.com/rancher/rke (Go) Fixed in 1.5.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32191
- 2026-10-03 Alias added: GHSA-6gr4-52w6-vmqx
- 2026-10-08 EPSS moved to the 50th–90th percentile
References
Other 5
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2023-32191
- https://github.com/rancher/rke/security/advisories/GHSA-6gr4-52w6-vmqx
- https://github.com/rancher/rke/commit/cf49199481a1891909acb1384eed73a5c987d5bd
- https://github.com/rancher/rke/commit/f7485b8dce376db0fc15a7c3ceb3de7029c8d0cf
- https://github.com/rancher/rke
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-32191 · CVE Program
- CVE-2023-32191 · NVD
- FIRST EPSS
- GHSA-6gr4-52w6-vmqx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences