Norman API Cross-site Scripting Vulnerability
Priority LOW 38CWE-80Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-80.
Summary
A vulnerability has been identified in which unauthenticated cross-site scripting (XSS) in Norman's public API endpoint can be exploited. This can lead to an attacker exploiting the vulnerability to trigger JavaScript code and execute commands remotely.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00467 40th percentileScored 2026-11-07
Fix Fixed norman (SUSE): 0.0.0-20240207153100-3bb70b772b52github.com/rancher/norman (Go): 0.0.0-20240207153100-3bb70b772b52
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | norman | before 0.0.0-20240207153100-3bb70b772b52 | 0.0.0-20240207153100-3bb70b772b52 | Patch available | CNA |
| — | github.com/rancher/norman (Go) | before 0.0.0-20240207153100-3bb70b772b52 | 0.0.0-20240207153100-3bb70b772b52 | Patch available | GHSA-r8f4-hv23-6qp6 |
- norman VendorSUSE Affected before 0.0.0-20240207153100-3bb70b772b52 Fixed in 0.0.0-20240207153100-3bb70b772b52 Patch available CNA
- github.com/rancher/norman (Go) Vendor— Affected before 0.0.0-20240207153100-3bb70b772b52 Fixed in 0.0.0-20240207153100-3bb70b772b52 Patch available GHSA-r8f4-hv23-6qp6
Remediation
- Fix · CNA norman (SUSE) Fixed in 0.0.0-20240207153100-3bb70b772b52
- Fix · GHSA-r8f4-hv23-6qp6 github.com/rancher/norman (Go) Fixed in 0.0.0-20240207153100-3bb70b772b52 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32193
- 2026-10-03 Alias added: GHSA-r8f4-hv23-6qp6
References
Other 8
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2023-32193
- https://github.com/rancher/norman/security/advisories/GHSA-r8f4-hv23-6qp6
- https://github.com/rancher/norman/commit/3bb70b772b52297feac64f5fdeb1b13c06c37e39
- https://github.com/rancher/norman/commit/7b2b467995e6dfab6d4a5dee8dffc15033ae8269
- https://github.com/rancher/norman/commit/a6a6cf5696088c32002953d36b75bdcc84f2399e
- https://github.com/rancher/norman/commit/bd13c653293b9b5e0b37e8a6ccd1c3277f4623ed
- https://github.com/rancher/norman/commit/cb54924f25c7666511a913cd41834299ef22dba4
- https://github.com/rancher/norman
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-32193 · CVE Program
- CVE-2023-32193 · NVD
- FIRST EPSS
- GHSA-r8f4-hv23-6qp6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences