Rancher's External RoleTemplates can lead to privilege escalation
Priority LOW 36CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- None
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-269.
Summary
A Improper Privilege Management vulnerability in SUSE rancher in RoleTemplateobjects when external=true is set can lead to privilege escalation in specific scenarios.This issue affects rancher: from 2.7.0 before 2.7.14, from 2.8.0 before 2.8.5.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00625 50th percentileScored 2026-11-07
Fix Fixed rancher (SUSE): 2.7.14, 2.8.5github.com/rancher/rancher (Go): 2.8.9, 2.9.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SUSE | rancher | 2.7.0 to before 2.7.14; 2.8.0 to before 2.8.5 | 2.7.14, 2.8.5 | Patch available | CNA |
| — | github.com/rancher/rancher (Go) | 2.7.0 to before 2.8.9 | 2.8.9 | Patch available | GHSA-7h8m-pvw3-5gh4 |
| — | github.com/rancher/rancher (Go) | 2.9.0 to before 2.9.3 | 2.9.3 | Patch available | GHSA-7h8m-pvw3-5gh4 |
- rancher VendorSUSE Affected 2.7.0 to before 2.7.14; 2.8.0 to before 2.8.5 Fixed in 2.7.14, 2.8.5 Patch available CNA
- github.com/rancher/rancher (Go) Vendor— Affected 2.7.0 to before 2.8.9 Fixed in 2.8.9 Patch available GHSA-7h8m-pvw3-5gh4
- github.com/rancher/rancher (Go) Vendor— Affected 2.9.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-7h8m-pvw3-5gh4
Remediation
- Fix · CNA rancher (SUSE) Fixed in 2.7.14, 2.8.5
- Fix · GHSA-7h8m-pvw3-5gh4 github.com/rancher/rancher (Go) Fixed in 2.8.9 Advisory →
- Fix · GHSA-7h8m-pvw3-5gh4 github.com/rancher/rancher (Go) Fixed in 2.9.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32197
- 2026-10-03 Alias added: GHSA-7h8m-pvw3-5gh4
- 2026-11-03 EPSS moved to the 50th–90th percentile
References
More SUSE vulnerabilities
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-03506 Adobe Flash Player 21.0.0.226 and earlier allows remote attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-02888 Unspecified vulnerability in Oracle Java SE 6u113, 7u99, and 8u77; Java SE Embedded 8u77… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04302 Use-after-free vulnerability in the BitmapData class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04301 Use-after-free vulnerability in the DisplayObject class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
- TI-2015-04298 Use-after-free vulnerability in the ByteArray class in the ActionScript 3 (AS3)… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-32197 · CVE Program
- CVE-2023-32197 · NVD
- FIRST EPSS
- GHSA-7h8m-pvw3-5gh4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences