Read the docs
TI-2023-15553 Aliases CVE-2023-32255GHSA-3hjh-cjx8-8c83

Kernel: memory leak via ksmbd session setup request with unknown ntlmssp message type

Priority LOW 31CWE-772Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-772.

Summary

A flaw was found in the Linux kernel's ksmbd component. A memory leak can occur if a client sends a session setup request with an unknown NTLMSSP message type, potentially leading to resource exhaustion.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00553 46th percentileScored 2026-11-07
Fix Fixed linux: 5.15.111, 6.1.28, 6.2.15 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—linuxbefore 5.15.111; 6.0.0 and later; 6.1.0 to before 6.1.28; 6.2.0 to before 6.2.15; 6.3.0 to before 6.3.25.15.111, 6.1.28, 6.2.15, 6.3.2Patch availableCNA
Red HatRed Hat Enterprise Linux 10——Not affectedCNA
Red HatRed Hat Enterprise Linux 6——Not affectedCNA
Red HatRed Hat Enterprise Linux 7——Not affectedCNA
Red HatRed Hat Enterprise Linux 7——Not affectedCNA
Red HatRed Hat Enterprise Linux 8——Not affectedCNA
Red HatRed Hat Enterprise Linux 8——Not affectedCNA
Red HatRed Hat Enterprise Linux 9——Not affectedCNA
Red HatRed Hat Enterprise Linux 9——Not affectedCNA
  • linux Vendor— Affected before 5.15.111; 6.0.0 and later; 6.1.0 to before 6.1.28; 6.2.0 to before 6.2.15; 6.3.0 to before 6.3.2 Fixed in 5.15.111, 6.1.28, 6.2.15, 6.3.2 Patch available CNA
  • Red Hat Enterprise Linux 10 VendorRed Hat Affected — Fixed in — Not affected CNA
  • Red Hat Enterprise Linux 6 VendorRed Hat Affected — Fixed in — Not affected CNA
  • Red Hat Enterprise Linux 7 VendorRed Hat Affected — Fixed in — Not affected CNA
  • Red Hat Enterprise Linux 7 VendorRed Hat Affected — Fixed in — Not affected CNA
  • Red Hat Enterprise Linux 8 VendorRed Hat Affected — Fixed in — Not affected CNA
  • Red Hat Enterprise Linux 8 VendorRed Hat Affected — Fixed in — Not affected CNA
  • Red Hat Enterprise Linux 9 VendorRed Hat Affected — Fixed in — Not affected CNA
  • Red Hat Enterprise Linux 9 VendorRed Hat Affected — Fixed in — Not affected CNA

CPE names CNA · 5

CPEVersionsRoleVendor
cpe:/o:redhat:enterprise_linux:1010—Red Hat
cpe:/o:redhat:enterprise_linux:66—Red Hat
cpe:/o:redhat:enterprise_linux:77—Red Hat
cpe:/o:redhat:enterprise_linux:88—Red Hat
cpe:/o:redhat:enterprise_linux:99—Red Hat
  • cpe:/o:redhat:enterprise_linux:10 Versions 10 — ·Red Hat
  • cpe:/o:redhat:enterprise_linux:6 Versions 6 — ·Red Hat
  • cpe:/o:redhat:enterprise_linux:7 Versions 7 — ·Red Hat
  • cpe:/o:redhat:enterprise_linux:8 Versions 8 — ·Red Hat
  • cpe:/o:redhat:enterprise_linux:9 Versions 9 — ·Red Hat

Remediation

  • Fix · CNA linux Fixed in 5.15.111, 6.1.28, 6.2.15, 6.3.2

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 5 products
  • Red Hat Enterprise Linux 10
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-32255
  2. 2026-10-03 Alias added: GHSA-3hjh-cjx8-8c83

References

  • TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2019-15874 Protection mechanism failure in Jenkins Script Security Plugin KEVCVSS 3.1CRITICAL 9.9
  • TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-05363 Code injection in Elastic Kibana KEVCVSS 3.1CRITICAL 10.0
  • TI-2019-03949 Out-of-bounds write in ESXi and Horizon DaaS KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-16080 A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153… KEVCVSS 3.1CRITICAL 9.8
See all 7413 →

Sources