Read the docs
TI-2023-15609 Aliases CVE-2023-32315GHSA-gw42-f939-fhvm

Openfire administration console authentication bypass

Priority CRITICAL 96Exploited in the wildCWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

Openfire is an XMPP server licensed under the Open Source Apache License. Openfire's administrative console, a web-based application, was found to be vulnerable to a path traversal attack via the setup environment. This permitted an unauthenticated user to use the unauthenticated Openfire Setup Environment in an already configured Openfire environment to access restricted pages in the Openfire Admin Console reserved for administrative users. This vulnerability affects all versions of Openfire that have been released since April 2015, starting with version 3.10.0. The problem has been patched in Openfire release 4.7.5 and 4.6.8, and further improvements will be included in the yet-to-be released first version on the 4.8 branch (which is expected to be version 4.8.0). Users are advised to upgrade. If an Openfire upgrade isn’t available for a specific release, or isn’t quickly actionable, users may see the linked github advisory (GHSA-gw42-f939-fhvm) for mitigation advice.

Why it matters now

Exploitation Active In CISA KEV since 2023-08-24CISA due date 2023-09-14
EPSS 0.99999 99th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Openfire (igniterealtime): 4.6.8, 4.7.5org.igniterealtime.openfire:xmppserver (Maven): 4.6.8, 4.7.5

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Active
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
igniterealtimeOpenfire3.10.0 to before 4.6.8; 4.7.0 to before 4.7.54.6.8, 4.7.5Patch availableCNA
—org.igniterealtime.openfire:xmppserver (Maven)3.10.0 to before 4.6.84.6.8Patch availableGHSA-gw42-f939-fhvm
—org.igniterealtime.openfire:xmppserver (Maven)4.7.0 to before 4.7.54.7.5Patch availableGHSA-gw42-f939-fhvm
  • Openfire Vendorigniterealtime Affected 3.10.0 to before 4.6.8; 4.7.0 to before 4.7.5 Fixed in 4.6.8, 4.7.5 Patch available CNA
  • org.igniterealtime.openfire:xmppserver (Maven) Vendor— Affected 3.10.0 to before 4.6.8 Fixed in 4.6.8 Patch available GHSA-gw42-f939-fhvm
  • org.igniterealtime.openfire:xmppserver (Maven) Vendor— Affected 4.7.0 to before 4.7.5 Fixed in 4.7.5 Patch available GHSA-gw42-f939-fhvm

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:igniterealtime:openfire:*:*:*:*:*:*:*:*3.10.0 to before 4.6.8; 4.7.0 to before 4.7.5Vulnerableigniterealtime
  • cpe:2.3:a:igniterealtime:openfire:*:*:*:*:*:*:*:* Versions 3.10.0 to before 4.6.8; 4.7.0 to before 4.7.5 Vulnerable ·igniterealtime

Remediation

  • Fix · CNA Openfire (igniterealtime) Fixed in 4.6.8, 4.7.5
  • Fix · GHSA-gw42-f939-fhvm org.igniterealtime.openfire:xmppserver (Maven) Fixed in 4.6.8 Advisory →
  • Fix · GHSA-gw42-f939-fhvm org.igniterealtime.openfire:xmppserver (Maven) Fixed in 4.7.5 Advisory →

Timeline

  1. 2023-08-24 Added to CISA KEV
  2. 2026-10-02 Threatist record created from CVE-2023-32315
  3. 2026-10-03 Alias added: GHSA-gw42-f939-fhvm

References

  • TI-2024-16737 An issue in Ignite Realtime Openfire v.4.9.0 and before allows a remote attacker to… CVSS 3.1CRITICAL 9.8
  • TI-2021-20964 An issue was discovered in Pascom Cloud Phone System before 7.20.x. CVSS 3.1CRITICAL 9.8
  • TI-2008-06198 Directory traversal vulnerability in the AuthCheck filter in the Admin Console in… CVSS 2.0HIGH 7.5
  • TI-2024-16736 An issue in Ignite Realtime Openfire before 4.8.1 allows a remote attacker to escalate… CVSS 3.1HIGH 7.2
  • TI-2019-13396 A Server Side Request Forgery (SSRF) vulnerability in FaviconServlet.java in Ignite… CVSS 3.1CRITICAL 9.8
  • TI-2015-05810 Multiple cross-site request forgery (CSRF) vulnerabilities in Ignite Realtime Openfire… CVSS 2.0MEDIUM 6.8
See all 36 →

Sources