Read the docs
TI-2023-15619 Aliases CVE-2023-32325GHSA-8775-5hwv-wr6v

Cross-site scripting in PostHog-js

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

PostHog-js is a library to interface with the PostHog analytics tool. Versions prior to 1.57.2 have the potential for cross-site scripting. Problem has been patched in 1.57.2. Users are advised to upgrade. Users unable to upgrade should ensure that their Content Security Policy is in place.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00429 37th percentileScored 2026-11-07
Fix Fixed posthog-js (PostHog): 1.57.2posthog-js (npm): 1.57.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PostHogposthog-jsbefore 1.57.21.57.2Patch availableCNA
—posthog-js (npm)before 1.57.21.57.2Patch availableGHSA-8775-5hwv-wr6v
  • posthog-js VendorPostHog Affected before 1.57.2 Fixed in 1.57.2 Patch available CNA
  • posthog-js (npm) Vendor— Affected before 1.57.2 Fixed in 1.57.2 Patch available GHSA-8775-5hwv-wr6v

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:posthog:posthog-js:*:*:*:*:*:*:*:*before 1.57.2VulnerablePostHog
  • cpe:2.3:a:posthog:posthog-js:*:*:*:*:*:*:*:* Versions before 1.57.2 Vulnerable ·PostHog

Remediation

  • Fix · CNA posthog-js (PostHog) Fixed in 1.57.2
  • Fix · GHSA-8775-5hwv-wr6v posthog-js (npm) Fixed in 1.57.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-32325
  2. 2026-10-03 Alias added: GHSA-8775-5hwv-wr6v

References

Sources