Invalid push request payload crashes Parse Server
Priority LOW 35CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
parse-server-push-adapter is the official Push Notification adapter for Parse Server. The Parse Server Push Adapter can crash Parse Server due to an invalid push notification payload. This issue has been patched in version 4.1.3.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.009 59th percentileScored 2026-11-07
Fix Fixed parse-server-push-adapter (parse-community): 4.1.3parse-server-push-adapter (npm): 4.1.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server-push-adapter | before 4.1.3 | 4.1.3 | Patch available | CNA |
| — | parse-server-push-adapter (npm) | before 4.1.3 | 4.1.3 | Patch available | GHSA-mxhg-rvwx-x993 |
- parse-server-push-adapter Vendorparse-community Affected before 4.1.3 Fixed in 4.1.3 Patch available CNA
- parse-server-push-adapter (npm) Vendor— Affected before 4.1.3 Fixed in 4.1.3 Patch available GHSA-mxhg-rvwx-x993
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse_server_push_adapter:*:*:*:*:*:node.js:*:* | before 4.1.3 | Vulnerable | parse-community |
- cpe:2.3:a:parseplatform:parse_server_push_adapter:*:*:*:*:*:node.js:*:* Versions before 4.1.3 Vulnerable ·parse-community
Remediation
- Fix · CNA parse-server-push-adapter (parse-community) Fixed in 4.1.3
- Fix · GHSA-mxhg-rvwx-x993 parse-server-push-adapter (npm) Fixed in 4.1.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32688
- 2026-10-03 Alias added: GHSA-mxhg-rvwx-x993
References
Patch 2
Sources
- CVE-2023-32688 · CVE Program
- CVE-2023-32688 · NVD
- FIRST EPSS
- GHSA-mxhg-rvwx-x993 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences