Information leak in gRPC
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Partial Red Hat: 1 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
When gRPC HTTP2 stack raised a header size exceeded error, it skipped parsing the rest of the HPACK frame. This caused any HPACK table mutations to also be skipped, resulting in a desynchronization of HPACK tables between sender and receiver. If leveraged, say, between a proxy and a backend, this could lead to requests from the proxy being interpreted as containing headers from different proxy clients - leading to an information leak that can be used for privilege escalation or data exfiltration. We recommend upgrading beyond the commit contained in https://github.com/grpc/grpc/pull/33005 https://github.com/grpc/grpc/pull/33005
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| gRPC | 1.53 – 1.54 | — | No fix listed | CNA | |
| — | io.grpc:grpc-protobuf (Maven) | 1.53.0 to before 1.53.1 | 1.53.1 | Patch available | GHSA-cfgp-2977-2fmm |
| — | grpcio (PyPI) | 1.53.0 to before 1.53.1 | 1.53.1 | Patch available | GHSA-cfgp-2977-2fmm |
| — | grpc (RubyGems) | 1.53.0 to before 1.53.1 | 1.53.1 | Patch available | GHSA-cfgp-2977-2fmm |
| — | grpcio (PyPI) | 1.54.0 to before 1.54.2 | 1.54.2 | Patch available | GHSA-cfgp-2977-2fmm |
| — | grpc (RubyGems) | 1.54.0 to before 1.54.2 | 1.54.2 | Patch available | GHSA-cfgp-2977-2fmm |
| — | io.grpc:grpc-protobuf (Maven) | 1.54.0 to before 1.54.2 | 1.54.2 | Patch available | GHSA-cfgp-2977-2fmm |
- gRPC VendorGoogle Affected 1.53 – 1.54 Fixed in — No fix listed CNA
- io.grpc:grpc-protobuf (Maven) Vendor— Affected 1.53.0 to before 1.53.1 Fixed in 1.53.1 Patch available GHSA-cfgp-2977-2fmm
- grpcio (PyPI) Vendor— Affected 1.53.0 to before 1.53.1 Fixed in 1.53.1 Patch available GHSA-cfgp-2977-2fmm
- grpc (RubyGems) Vendor— Affected 1.53.0 to before 1.53.1 Fixed in 1.53.1 Patch available GHSA-cfgp-2977-2fmm
- grpcio (PyPI) Vendor— Affected 1.54.0 to before 1.54.2 Fixed in 1.54.2 Patch available GHSA-cfgp-2977-2fmm
- grpc (RubyGems) Vendor— Affected 1.54.0 to before 1.54.2 Fixed in 1.54.2 Patch available GHSA-cfgp-2977-2fmm
- io.grpc:grpc-protobuf (Maven) Vendor— Affected 1.54.0 to before 1.54.2 Fixed in 1.54.2 Patch available GHSA-cfgp-2977-2fmm
Remediation
- Fix · GHSA-cfgp-2977-2fmm io.grpc:grpc-protobuf (Maven) Fixed in 1.53.1 Advisory →
- Fix · GHSA-cfgp-2977-2fmm grpcio (PyPI) Fixed in 1.53.1 Advisory →
- Fix · GHSA-cfgp-2977-2fmm grpc (RubyGems) Fixed in 1.53.1 Advisory →
- Fix · GHSA-cfgp-2977-2fmm grpcio (PyPI) Fixed in 1.54.2 Advisory →
- Fix · GHSA-cfgp-2977-2fmm grpc (RubyGems) Fixed in 1.54.2 Advisory →
- Fix · GHSA-cfgp-2977-2fmm io.grpc:grpc-protobuf (Maven) Fixed in 1.54.2 Advisory →
Red Hat 1 advisory
- RHSA-2024:10761 Released 2024-12-03 · Red Hat rating Importantrhc-worker-playbook security update
- Red Hat Enterprise Linux AppStream (v. 9) rhc-worker-playbook-0.1.10-1.el9_5
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2024:10761 |
Not affected: 1 product
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32731
- 2026-10-03 Alias added: GHSA-cfgp-2977-2fmm
References
Other 6
- https://github.com/grpc/grpc/issues/33463
- https://github.com/grpc/grpc/commit/29d8beee0ac2555773b2a2dda5601c74a95d6c10
- https://github.com/grpc/grpc/commit/65a2a895afaf1d2072447b9baf246374b182a946
- https://github.com/grpc/grpc/releases/tag/v1.53.1
- https://github.com/grpc/grpc/releases/tag/v1.54.2
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/grpc/CVE-2023-32731.yml
More Google vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2023-32731 · CVE Program
- CVE-2023-32731 · NVD
- FIRST EPSS
- GHSA-cfgp-2977-2fmm · GitHub Advisory Database · CC BY 4.0
- CVE-2023-32731 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences