Reactor Netty HTTP Server Metrics DoS Vulnerability
Priority LOW 35Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
In Reactor Netty HTTP Server, versions 1.1.x prior to 1.1.13 and versions 1.0.x prior to 1.0.39, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Specifically, an application is vulnerable if Reactor Netty HTTP Server built-in integration with Micrometer is enabled.
Why it matters now
EPSS 0.00914 60th percentileScored 2026-11-07
Fix Fixed Reactor Netty (Spring): 1.1.13, 1.0.39io.projectreactor.netty:reactor-netty-core (Maven): 1.1.13, 1.0.39
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| VMware | Reactor Netty | 1.1.0 to before 1.1.13; 1.0.0 to before 1.0.39; older unsupported versions | 1.1.13, 1.0.39 | Patch available | CNA |
| — | io.projectreactor.netty:reactor-netty-core (Maven) | 1.1.0 to before 1.1.13 | 1.1.13 | Patch available | GHSA-q24v-hpg3-v3jp |
| — | io.projectreactor.netty:reactor-netty-core (Maven) | 1.0.0 to before 1.0.39 | 1.0.39 | Patch available | GHSA-q24v-hpg3-v3jp |
- Reactor Netty VendorVMware Affected 1.1.0 to before 1.1.13; 1.0.0 to before 1.0.39; older unsupported versions Fixed in 1.1.13, 1.0.39 Patch available CNA
- io.projectreactor.netty:reactor-netty-core (Maven) Vendor— Affected 1.1.0 to before 1.1.13 Fixed in 1.1.13 Patch available GHSA-q24v-hpg3-v3jp
- io.projectreactor.netty:reactor-netty-core (Maven) Vendor— Affected 1.0.0 to before 1.0.39 Fixed in 1.0.39 Patch available GHSA-q24v-hpg3-v3jp
Remediation
- Fix · CNA Reactor Netty (Spring) Fixed in 1.1.13, 1.0.39
- Fix · GHSA-q24v-hpg3-v3jp io.projectreactor.netty:reactor-netty-core (Maven) Fixed in 1.1.13 Advisory →
- Fix · GHSA-q24v-hpg3-v3jp io.projectreactor.netty:reactor-netty-core (Maven) Fixed in 1.0.39 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-34054
- 2026-10-03 Alias added: GHSA-q24v-hpg3-v3jp
References
Other 6
- https://github.com/reactor/reactor-netty/commit/37dc8a2ef6514cd7834e75e7f3faf0b9ea044c88
- https://github.com/reactor/reactor-netty/commit/4ddbb1b9b985bb72290110ebae468a54e7f19420
- https://github.com/reactor/reactor-netty/commit/ae82154e99e6f51f4816effd135f0c3a966d6ea3
- https://github.com/reactor/reactor-netty
- https://github.com/reactor/reactor-netty/releases/tag/v1.0.39
- https://github.com/reactor/reactor-netty/releases/tag/v1.1.13
More VMware vulnerabilities
- TI-2026-42442 vCenter directory-traversal vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26040 Privilege escalation in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-26039 Heap-overflow in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2024-24610 Out-of-bounds write in VMware vCenter Server KEVCVSS 3.1CRITICAL 9.8
- TI-2023-16914 VMware vCenter Server Out-of-Bounds Write Vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2023-07303 Command injection in Aria Operations for Networks KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-34054 · CVE Program
- CVE-2023-34054 · NVD
- FIRST EPSS
- GHSA-q24v-hpg3-v3jp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences