Read the docs
TI-2023-17801 Aliases CVE-2023-35701GHSA-vpw3-3prf-3974

Apache Hive: Arbitrary command execution via JDBC driver

Priority LOW 33CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
High
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Hive. The vulnerability affects the Hive JDBC driver component and it can potentially lead to arbitrary code execution on the machine/endpoint that the JDBC driver (client) is running. The malicious user must have sufficient permissions to specify/edit JDBC URL(s) in an endpoint relying on the Hive JDBC driver and the JDBC client process must run under a privileged user to fully exploit the vulnerability.  The attacker can setup a malicious HTTP server and specify a JDBC URL pointing towards this server. When a JDBC connection is attempted, the malicious HTTP server can provide a special response with customized payload that can trigger the execution of certain commands in the JDBC client.This issue affects Apache Hive: from 4.0.0-alpha-1 before 4.0.0. Users are recommended to upgrade to version 4.0.0, which fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01103 65th percentileScored 2026-11-07
Fix Fixed Apache Hive (Apache Software Foundation): 4.0.0org.apache.hive:hive-jdbc (Maven): 4.0.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Hive4.0.0-alpha-1 to before 4.0.04.0.0Patch availableCNA
—org.apache.hive:hive-jdbc (Maven)4.0.0-alpha-1 to before 4.0.04.0.0Patch availableGHSA-vpw3-3prf-3974
  • Apache Hive VendorApache Affected 4.0.0-alpha-1 to before 4.0.0 Fixed in 4.0.0 Patch available CNA
  • org.apache.hive:hive-jdbc (Maven) Vendor— Affected 4.0.0-alpha-1 to before 4.0.0 Fixed in 4.0.0 Patch available GHSA-vpw3-3prf-3974

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:apache:hive:4.0.0:alpha1:*:*:*:*:*:*4.0.0 alpha1VulnerableApache
cpe:2.3:a:apache:hive:4.0.0:alpha2:*:*:*:*:*:*4.0.0 alpha2VulnerableApache
cpe:2.3:a:apache:hive:4.0.0:beta1:*:*:*:*:*:*4.0.0 beta1VulnerableApache
  • cpe:2.3:a:apache:hive:4.0.0:alpha1:*:*:*:*:*:* Versions 4.0.0 alpha1 Vulnerable ·Apache
  • cpe:2.3:a:apache:hive:4.0.0:alpha2:*:*:*:*:*:* Versions 4.0.0 alpha2 Vulnerable ·Apache
  • cpe:2.3:a:apache:hive:4.0.0:beta1:*:*:*:*:*:* Versions 4.0.0 beta1 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Hive (Apache Software Foundation) Fixed in 4.0.0
  • Fix · GHSA-vpw3-3prf-3974 org.apache.hive:hive-jdbc (Maven) Fixed in 4.0.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-35701
  2. 2026-10-03 Alias added: GHSA-vpw3-3prf-3974

References

  • TI-2018-15196 Jodd before 5.0.4 performs Deserialization of Untrusted JSON Data when setClassMetadataName is set. CVSS 3.1CRITICAL 9.8
  • TI-2026-40376 Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url CVSS 3.1CRITICAL 9.1
  • TI-2018-01187 SQL injection in Apache Hive CVSS 3.0CRITICAL 9.1
  • TI-2026-36749 Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths CVSS 3.1CRITICAL 9.8
  • TI-2015-06259 The authorization framework in Apache Hive 1.0.0, 1.0.1, 1.1.0, 1.1.1, 1.2.0 and 1.2.1… CVSS 3.0HIGH 8.3
  • TI-2020-10925 Uncontrolled resource consumption in Apache Thrift CVSS 3.1HIGH 7.5
See all 22 →

Sources