Read the docs
TI-2023-18309 Aliases CVE-2023-36468GHSA-8q9q-r9v2-644m

Upgrading doesn't prevent exploiting vulnerable XWiki documents

Priority HIGH 76CWE-459Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. When an XWiki installation is upgraded and that upgrade contains a fix for a bug in a document, just a new version of that document is added. In some cases, it's still possible to exploit the vulnerability that was fixed in the new version. The severity of this depends on the fixed vulnerability, for the purpose of this advisory take CVE-2022-36100/GHSA-2g5c-228j-p52x as example - it is easily exploitable with just view rights and critical. When XWiki is upgraded from a version before the fix for it (e.g., 14.3) to a version including the fix (e.g., 14.4), the vulnerability can still be reproduced by adding `rev=1.1` to the URL used in the reproduction steps so remote code execution is possible even after upgrading. Therefore, this affects the confidentiality, integrity and availability of the whole XWiki installation. This vulnerability also affects manually added script macros that contained security vulnerabilities that were later fixed by changing the script macro without deleting the versions with the security vulnerability from the history. This vulnerability doesn't affect freshly installed versions of XWiki. Further, this vulnerability doesn't affect content that is only loaded from the current version of a document like the code of wiki macros or UI extensions. This vulnerability has been patched in XWiki 14.10.7 and 15.2RC1 by forcing old revisions to be executed in a restricted mode that disables all script macros. As a workaround, admins can manually delete old revisions of affected documents. A script could be used to identify all installed documents and delete the history for them. However, also manually added and later corrected code may be affected by this vulnerability so it is easy to miss documents.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01861 79th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed xwiki-platform (xwiki): 14.10.7, 15.2-rc-1org.xwiki.platform:xwiki-platform-oldcore (Maven): 14.10.7, 15.2-rc-1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
XWikixwiki-platform2.0 to before 14.10.7; 15.0-rc-1 to before 15.2-rc-114.10.7, 15.2-rc-1Patch availableCNA
—org.xwiki.platform:xwiki-platform-oldcore (Maven)2.0 to before 14.10.714.10.7Patch availableGHSA-8q9q-r9v2-644m
—org.xwiki.platform:xwiki-platform-oldcore (Maven)15.0-rc-1 to before 15.2-rc-115.2-rc-1Patch availableGHSA-8q9q-r9v2-644m
  • xwiki-platform VendorXWiki Affected 2.0 to before 14.10.7; 15.0-rc-1 to before 15.2-rc-1 Fixed in 14.10.7, 15.2-rc-1 Patch available CNA
  • org.xwiki.platform:xwiki-platform-oldcore (Maven) Vendor— Affected 2.0 to before 14.10.7 Fixed in 14.10.7 Patch available GHSA-8q9q-r9v2-644m
  • org.xwiki.platform:xwiki-platform-oldcore (Maven) Vendor— Affected 15.0-rc-1 to before 15.2-rc-1 Fixed in 15.2-rc-1 Patch available GHSA-8q9q-r9v2-644m

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:xwiki:xwiki:*:*:*:*:*:*:*:*2.0 to before 14.10.7VulnerableXWiki
cpe:2.3:a:xwiki:xwiki:15.0:-:*:*:*:*:*:*15.0VulnerableXWiki
cpe:2.3:a:xwiki:xwiki:15.0:rc1:*:*:*:*:*:*15.0 rc1VulnerableXWiki
cpe:2.3:a:xwiki:xwiki:15.1:-:*:*:*:*:*:*15.1VulnerableXWiki
cpe:2.3:a:xwiki:xwiki:15.1:rc1:*:*:*:*:*:*15.1 rc1VulnerableXWiki
  • cpe:2.3:a:xwiki:xwiki:*:*:*:*:*:*:*:* Versions 2.0 to before 14.10.7 Vulnerable ·XWiki
  • cpe:2.3:a:xwiki:xwiki:15.0:-:*:*:*:*:*:* Versions 15.0 Vulnerable ·XWiki
  • cpe:2.3:a:xwiki:xwiki:15.0:rc1:*:*:*:*:*:* Versions 15.0 rc1 Vulnerable ·XWiki
  • cpe:2.3:a:xwiki:xwiki:15.1:-:*:*:*:*:*:* Versions 15.1 Vulnerable ·XWiki
  • cpe:2.3:a:xwiki:xwiki:15.1:rc1:*:*:*:*:*:* Versions 15.1 rc1 Vulnerable ·XWiki

Remediation

  • Fix · CNA xwiki-platform (xwiki) Fixed in 14.10.7, 15.2-rc-1
  • Fix · GHSA-8q9q-r9v2-644m org.xwiki.platform:xwiki-platform-oldcore (Maven) Fixed in 14.10.7 Advisory →
  • Fix · GHSA-8q9q-r9v2-644m org.xwiki.platform:xwiki-platform-oldcore (Maven) Fixed in 15.2-rc-1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-36468
  2. 2026-10-03 Alias added: GHSA-8q9q-r9v2-644m

References

  • TI-2025-18595 Remote code execution as guest via SolrSearchMacros request in xwiki KEVCVSS 3.1CRITICAL 9.8
  • TI-2023-25214 Remote code execution through the section parameter in Administration as guest in XWiki Platform CVSS 3.1CRITICAL 10.0
  • TI-2025-23500 XWiki Platform vulnerable to SQL injection through getdeleteddocuments.vm template sort parameter CVSS 4.0CRITICAL 9.3
  • TI-2025-23979 org.xwiki.platform:xwiki-platform-rest-server allows SQL injection in query endpoint of REST API CVSS 4.0CRITICAL 9.3
  • TI-2024-20829 XWiki Platform: Remote code execution from account via SearchSuggestSourceSheet CVSS 3.1CRITICAL 10.0
  • TI-2024-14375 XWiki Remote Code Execution vulnerability via user registration CVSS 3.1CRITICAL 10.0
See all 247 →

Sources