SQLFluff vulnerability for users with access to config file, using `library_path` to call arbitrary python code.
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
SQLFluff is a SQL linter. Prior to version 2.1.2, in environments where untrusted users have access to the config files, there is a potential security vulnerability where those users could use the `library_path` config value to allow arbitrary python code to be executed via macros. For many users who use SQLFluff in the context of an environment where all users already have fairly escalated privileges, this may not be an issue - however in larger user bases, or where SQLFluff is bundled into another tool where developers still wish to give users access to supply their on rule configuration, this may be an issue. The 2.1.2 release offers the ability for the `library_path` argument to be overwritten on the command line by using the `--library-path` option. This overrides any values provided in the config files and effectively prevents this route of attack for users which have access to the config file, but not to the scripts which call the SQLFluff CLI directly. A similar option is provided for the Python API, where users also have a greater ability to further customise or override configuration as necessary. Unless `library_path` is explicitly required, SQLFluff maintainers recommend using the option `--library-path none` when invoking SQLFluff which will disable the `library-path` option entirely regardless of the options set in the configuration file or via inline config directives. As a workaround, limiting access to - or otherwise validating configuration files before they are ingested by SQLFluff will provides a similar effect and does not require upgrade.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| sqlfluff | sqlfluff | before 2.1.2 | 2.1.2 | Patch available | CNA |
| — | sqlfluff (PyPI) | before 2.1.2 | 2.1.2 | Patch available | GHSA-jqhc-m2j3-fjrx |
- sqlfluff Vendorsqlfluff Affected before 2.1.2 Fixed in 2.1.2 Patch available CNA
- sqlfluff (PyPI) Vendor— Affected before 2.1.2 Fixed in 2.1.2 Patch available GHSA-jqhc-m2j3-fjrx
Remediation
- Fix · CNA sqlfluff (sqlfluff) Fixed in 2.1.2
- Fix · GHSA-jqhc-m2j3-fjrx sqlfluff (PyPI) Fixed in 2.1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-36830
- 2026-10-03 Alias added: GHSA-jqhc-m2j3-fjrx
References
More Sqlfluff vulnerabilities
- TI-2026-34091 SQLFluff: Uncontrolled Resource Consumption in Parser CVSS 3.1HIGH 7.5
- TI-2026-34090 SQLFluff: Recursive Stack Overflow in Parser CVSS 3.1HIGH 7.5
Sources
- CVE-2023-36830 · CVE Program
- CVE-2023-36830 · NVD
- FIRST EPSS
- GHSA-jqhc-m2j3-fjrx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences