Read the docs
TI-2023-19180 Aliases CVE-2023-37582GHSA-gpq8-963w-8qc9

Apache RocketMQ: Possible remote code execution when using the update configuration function

Priority CRITICAL 92CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

The RocketMQ NameServer component still has a remote command execution vulnerability as the CVE-2023-33246 issue was not completely fixed in version 5.1.1. When NameServer address are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function on the NameServer component to execute commands as the system users that RocketMQ is running as. It is recommended for users to upgrade their NameServer version to 5.1.2 or above for RocketMQ 5.x or 4.9.7 or above for RocketMQ 4.x to prevent these attacks.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.90427 99th percentileScored 2026-11-07
Fix Fixed org.apache.rocketmq:rocketmq-namesrv (Maven): 4.9.7, 5.1.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache RocketMQ5.0.0 – 5.1.1; up to 4.9.6—No fix listedCNA
—org.apache.rocketmq:rocketmq-namesrv (Maven)before 4.9.74.9.7Patch availableGHSA-gpq8-963w-8qc9
—org.apache.rocketmq:rocketmq-namesrv (Maven)5.0.0 to before 5.1.25.1.2Patch availableGHSA-gpq8-963w-8qc9
  • Apache RocketMQ VendorApache Affected 5.0.0 – 5.1.1; up to 4.9.6 Fixed in — No fix listed CNA
  • org.apache.rocketmq:rocketmq-namesrv (Maven) Vendor— Affected before 4.9.7 Fixed in 4.9.7 Patch available GHSA-gpq8-963w-8qc9
  • org.apache.rocketmq:rocketmq-namesrv (Maven) Vendor— Affected 5.0.0 to before 5.1.2 Fixed in 5.1.2 Patch available GHSA-gpq8-963w-8qc9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:rocketmq:*:*:*:*:*:*:*:*up to 4.9.6; 5.0.0 – 5.1.1VulnerableApache
  • cpe:2.3:a:apache:rocketmq:*:*:*:*:*:*:*:* Versions up to 4.9.6; 5.0.0 – 5.1.1 Vulnerable ·Apache

Remediation

  • Fix · GHSA-gpq8-963w-8qc9 org.apache.rocketmq:rocketmq-namesrv (Maven) Fixed in 4.9.7 Advisory →
  • Fix · GHSA-gpq8-963w-8qc9 org.apache.rocketmq:rocketmq-namesrv (Maven) Fixed in 5.1.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-37582
  2. 2026-10-03 Alias added: GHSA-gpq8-963w-8qc9

References

  • TI-2023-16418 Apache RocketMQ: Possible remote code execution vulnerability when using the update configuration function KEVCVSS 3.1CRITICAL 9.8
  • TI-2024-15423 Apache RocketMQ: Unauthorized Exposure of Sensitive Data CVSS 3.1HIGH 8.8
  • TI-2019-13114 Path traversal in Apache RocketMQ CVSS 3.1MEDIUM 5.3

Sources