feathersjs socket handler allows abusing implicit toString
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Feathersjs is a framework for creating web APIs and real-time applications with TypeScript or JavaScript. Feathers socket handler did not catch invalid string conversion errors like `const message = ${{ toString: '' }}` which would cause the NodeJS process to crash when sending an unexpected Socket.io message like `socket.emit('find', { toString: '' })`. A fix has been released in versions 5.0.8 and 4.5.18. Users are advised to upgrade. There is no known workaround for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| feathersjs | feathers | before 4.5.18; 5.0.0 to before 5.0.8 | 4.5.18, 5.0.8 | Patch available | CNA |
| — | @feathersjs/socketio (npm) | before 4.5.18 | 4.5.18 | Patch available | GHSA-hhr9-rh25-hvf9 |
| — | @feathersjs/socketio (npm) | 5.0.0 to before 5.0.8 | 5.0.8 | Patch available | GHSA-hhr9-rh25-hvf9 |
| — | @feathersjs/transport-commons (npm) | before 4.5.18 | 4.5.18 | Patch available | GHSA-hhr9-rh25-hvf9 |
| — | @feathersjs/transport-commons (npm) | 5.0.0 to before 5.0.8 | 5.0.8 | Patch available | GHSA-hhr9-rh25-hvf9 |
- feathers Vendorfeathersjs Affected before 4.5.18; 5.0.0 to before 5.0.8 Fixed in 4.5.18, 5.0.8 Patch available CNA
- @feathersjs/socketio (npm) Vendor— Affected before 4.5.18 Fixed in 4.5.18 Patch available GHSA-hhr9-rh25-hvf9
- @feathersjs/socketio (npm) Vendor— Affected 5.0.0 to before 5.0.8 Fixed in 5.0.8 Patch available GHSA-hhr9-rh25-hvf9
- @feathersjs/transport-commons (npm) Vendor— Affected before 4.5.18 Fixed in 4.5.18 Patch available GHSA-hhr9-rh25-hvf9
- @feathersjs/transport-commons (npm) Vendor— Affected 5.0.0 to before 5.0.8 Fixed in 5.0.8 Patch available GHSA-hhr9-rh25-hvf9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:feathersjs:feathers:*:*:*:*:*:node.js:*:* | before 4.5.18; 5.0.0 to before 5.0.8 | Vulnerable | feathersjs |
- cpe:2.3:a:feathersjs:feathers:*:*:*:*:*:node.js:*:* Versions before 4.5.18; 5.0.0 to before 5.0.8 Vulnerable ·feathersjs
Remediation
- Fix · CNA feathers (feathersjs) Fixed in 4.5.18, 5.0.8
- Fix · GHSA-hhr9-rh25-hvf9 @feathersjs/socketio (npm) Fixed in 4.5.18 Advisory →
- Fix · GHSA-hhr9-rh25-hvf9 @feathersjs/socketio (npm) Fixed in 5.0.8 Advisory →
- Fix · GHSA-hhr9-rh25-hvf9 @feathersjs/transport-commons (npm) Fixed in 4.5.18 Advisory →
- Fix · GHSA-hhr9-rh25-hvf9 @feathersjs/transport-commons (npm) Fixed in 5.0.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-37899
- 2026-10-03 Alias added: GHSA-hhr9-rh25-hvf9
References
Patch 2
Other 5
- https://github.com/feathersjs/feathers/blob/crow/CHANGELOG.md#4518-2023-07-19
- https://github.com/feathersjs/feathers/blob/dove/CHANGELOG.md#508-2023-07-19
- https://github.com/feathersjs/feathers/commit/0b9a6b19b12ad05934e4c8bd9917448ed39d1ed8
- https://github.com/feathersjs/feathers/commit/c397ab3a0cd184044ae4f73540549b30a396821c
- https://github.com/feathersjs/feathers
More feathersjs Feathers vulnerabilities
- TI-2026-23379 NoSQL Injection via WebSocket id Parameter in MongoDB Adapter CVSS 4.0CRITICAL 9.3
- TI-2026-23378 Feathersjs has an OAuth Callback Account Takeover CVSS 4.0CRITICAL 9.3
- TI-2026-21630 Feathers exposes internal headers via unencrypted session cookie CVSS 4.0HIGH 8.2
- TI-2026-21629 Feathers has an origin validation bypass via prefix matching CVSS 4.0HIGH 7.6
- TI-2026-21628 Feathers: Open Redirect in OAuth callback enables account takeover CVSS 4.0HIGH 7.4
Sources
- CVE-2023-37899 · CVE Program
- CVE-2023-37899 · NVD
- FIRST EPSS
- GHSA-hhr9-rh25-hvf9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences