Cross-site Scripting (XSS) in Source Mode of Editor in ckeditor-wordcount-plugin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
ckeditor-wordcount-plugin is an open source WordCount Plugin for CKEditor. It has been discovered that the `ckeditor-wordcount-plugin` plugin for CKEditor4 is susceptible to cross-site scripting when switching to the source code mode. This issue has been addressed in version 1.17.12 of the `ckeditor-wordcount-plugin` plugin and users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| w8tcha | CKEditor-WordCount-Plugin | before 1.17.12 | 1.17.12 | Patch available | CNA |
| TYPO3 | cms-rte-ckeditor | 10.0.0 to before 10.4.39; 11.0.0 to before 11.5.30 | 10.4.39, 11.5.30 | Patch available | CNA |
| — | ckeditor-wordcount-plugin (npm) | before 1.17.12 | 1.17.12 | Patch available | GHSA-q9w4-w667-qqj4 |
- CKEditor-WordCount-Plugin Vendorw8tcha Affected before 1.17.12 Fixed in 1.17.12 Patch available CNA
- cms-rte-ckeditor VendorTYPO3 Affected 10.0.0 to before 10.4.39; 11.0.0 to before 11.5.30 Fixed in 10.4.39, 11.5.30 Patch available CNA
- ckeditor-wordcount-plugin (npm) Vendor— Affected before 1.17.12 Fixed in 1.17.12 Patch available GHSA-q9w4-w667-qqj4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ckeditor-wordcount-plugin_project:ckeditor-wordcount-plugin:*:*:*:*:*:node.js:*:* | before 1.17.12 | Vulnerable | Ckeditor-wordcount-plugin Project |
- cpe:2.3:a:ckeditor-wordcount-plugin_project:ckeditor-wordcount-plugin:*:*:*:*:*:node.js:*:* Versions before 1.17.12 Vulnerable ·Ckeditor-wordcount-plugin Project
Remediation
- Fix · CNA CKEditor-WordCount-Plugin (w8tcha) Fixed in 1.17.12
- Fix · CNA cms-rte-ckeditor (typo3) Fixed in 10.4.39, 11.5.30
- Fix · GHSA-q9w4-w667-qqj4 ckeditor-wordcount-plugin (npm) Fixed in 1.17.12 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-37905
- 2026-10-03 Alias added: GHSA-q9w4-w667-qqj4
References
Patch 2
Advisory 2
More TYPO3 vulnerabilities
- TI-2023-10314 Persisted Cross-Site Scripting in Frontend Rendering in typo3 CVSS 3.1HIGH 8.8
- TI-2010-03538 The jumpUrl (aka access tracking) implementation in tslib/class.tslib_fe.php in TYPO3… CVSS 2.0HIGH 7.1
- TI-2009-00775 The jumpUrl mechanism in class.tslib_fe.php in TYPO3 3.3.x through 3.8.x, 4.0 before… CVSS 2.0MEDIUM 5.0
- TI-2025-30547 The sr_feuser_register extension through 12.4.8 for TYPO3 allows Remote Code Execution. CVSS 3.1CRITICAL 10.0
- TI-2019-08867 The PharStreamWrapper (aka phar-stream-wrapper) package 2.x before 2.1.1 and 3.x before… CVSS 3.1CRITICAL 9.8
- TI-2008-04019 Unspecified vulnerability in the TYPO3 Secure Directory (kw_secdir) extension before… CVSS 2.0HIGH 10.0
Sources
- CVE-2023-37905 · CVE Program
- CVE-2023-37905 · NVD
- FIRST EPSS
- GHSA-q9w4-w667-qqj4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences