Kirby vulnerable to field injection in the KirbyData text storage handler
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
Kirby is a content management system. A vulnerability in versions prior to 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6 affects all Kirby sites that might have potential attackers in the group of authenticated Panel users or that allow external visitors to update a Kirby content file (e.g. via a contact or comment form). Kirby sites are *not* affected if they don't allow write access for untrusted users or visitors. A field injection in a content storage implementation is a type of vulnerability that allows attackers with content write access to overwrite content fields that the site developer didn't intend to be modified. In a Kirby site this can be used to alter site content, break site behavior or inject malicious data or code. The exact security risk depends on the field type and usage. Kirby stores content of the site, of pages, files and users in text files by default. The text files use Kirby's KirbyData format where each field is separated by newlines and a line with four dashes (`----`). When reading a KirbyData file, the affected code first removed the Unicode BOM sequence from the file contents and afterwards split the content into fields by the field separator. When writing to a KirbyData file, field separators in field data are escaped to prevent user input from interfering with the field structure. However this escaping could be tricked by including a Unicode BOM sequence in a field separator (e.g. `--\xEF\xBB\xBF--`). When writing, this was not detected as a separator, but because the BOM was removed during reading, it could be abused by attackers to inject other field data into content files. Because each field can only be defined once per content file, this vulnerability only affects fields in the content file that were defined above the vulnerable user-writable field or not at all. Fields that are defined below the vulnerable field override the injected field content and were therefore already protected. The problem has been patched in Kirby 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6. In all of the mentioned releases, the maintainers have fixed the affected code to only remove the Unicode BOM sequence at the beginning of the file. This fixes this vulnerability both for newly written as well as for existing content files.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| getkirby | kirby | before 3.5.8.3; 3.6.0 to before 3.6.6.3; 3.7.0 to before 3.7.5.2; 3.8.0 to before 3.8.41; 3.9.0 to before 3.9.6 | 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.41, 3.9.6 | Patch available | CNA |
| — | getkirby/cms (Packagist) | before 3.5.8.3 | 3.5.8.3 | Patch available | GHSA-x5mr-p6v4-wp93 |
| — | getkirby/cms (Packagist) | 3.6.0 to before 3.6.6.3 | 3.6.6.3 | Patch available | GHSA-x5mr-p6v4-wp93 |
| — | getkirby/cms (Packagist) | 3.7.0 to before 3.7.5.2 | 3.7.5.2 | Patch available | GHSA-x5mr-p6v4-wp93 |
| — | getkirby/cms (Packagist) | 3.8.0 to before 3.8.4.1 | 3.8.4.1 | Patch available | GHSA-x5mr-p6v4-wp93 |
| — | getkirby/cms (Packagist) | 3.9.0 to before 3.9.6 | 3.9.6 | Patch available | GHSA-x5mr-p6v4-wp93 |
- kirby Vendorgetkirby Affected before 3.5.8.3; 3.6.0 to before 3.6.6.3; 3.7.0 to before 3.7.5.2; 3.8.0 to before 3.8.41; 3.9.0 to before 3.9.6 Fixed in 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.41, 3.9.6 Patch available CNA
- getkirby/cms (Packagist) Vendor— Affected before 3.5.8.3 Fixed in 3.5.8.3 Patch available GHSA-x5mr-p6v4-wp93
- getkirby/cms (Packagist) Vendor— Affected 3.6.0 to before 3.6.6.3 Fixed in 3.6.6.3 Patch available GHSA-x5mr-p6v4-wp93
- getkirby/cms (Packagist) Vendor— Affected 3.7.0 to before 3.7.5.2 Fixed in 3.7.5.2 Patch available GHSA-x5mr-p6v4-wp93
- getkirby/cms (Packagist) Vendor— Affected 3.8.0 to before 3.8.4.1 Fixed in 3.8.4.1 Patch available GHSA-x5mr-p6v4-wp93
- getkirby/cms (Packagist) Vendor— Affected 3.9.0 to before 3.9.6 Fixed in 3.9.6 Patch available GHSA-x5mr-p6v4-wp93
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:* | 3.5.0 to before 3.5.8.3; 3.6.0 to before 3.6.6.3; 3.7.0 to before 3.7.5.2; 3.8.0 to before 3.8.4.1; 3.9.0 to before 3.9.6 | Vulnerable | getkirby |
- cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:* Versions 3.5.0 to before 3.5.8.3; 3.6.0 to before 3.6.6.3; 3.7.0 to before 3.7.5.2; 3.8.0 to before 3.8.4.1; 3.9.0 to before 3.9.6 Vulnerable ·getkirby
Remediation
- Fix · CNA kirby (getkirby) Fixed in 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.41, 3.9.6
- Fix · GHSA-x5mr-p6v4-wp93 getkirby/cms (Packagist) Fixed in 3.5.8.3 Advisory →
- Fix · GHSA-x5mr-p6v4-wp93 getkirby/cms (Packagist) Fixed in 3.6.6.3 Advisory →
- Fix · GHSA-x5mr-p6v4-wp93 getkirby/cms (Packagist) Fixed in 3.7.5.2 Advisory →
- Fix · GHSA-x5mr-p6v4-wp93 getkirby/cms (Packagist) Fixed in 3.8.4.1 Advisory →
- Fix · GHSA-x5mr-p6v4-wp93 getkirby/cms (Packagist) Fixed in 3.9.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-38488
- 2026-10-03 Alias added: GHSA-x5mr-p6v4-wp93
References
Advisory 7
- https://github.com/getkirby/kirby/security/advisories/GHSA-x5mr-p6v4-wp93
- https://github.com/getkirby/kirby/releases/tag/3.5.8.3
- https://github.com/getkirby/kirby/releases/tag/3.6.6.3
- https://github.com/getkirby/kirby/releases/tag/3.7.5.2
- https://github.com/getkirby/kirby/releases/tag/3.8.4.1
- https://github.com/getkirby/kirby/releases/tag/3.9.6
- https://nvd.nist.gov/vuln/detail/CVE-2023-38488
More getkirby Kirby vulnerabilities
- TI-2024-17440 An arbitrary file upload vulnerability in the Profile Image module of Kirby CMS v4.1.0… CVSS 3.1HIGH 8.8
- TI-2024-17439 An HTML injection vulnerability exists in the Edit Content Layout module of Kirby CMS… CVSS 3.1HIGH 7.1
- TI-2026-23396 Kirby CMS through 5.1.4 allows an authenticated user with 'Editor' permissions to cause a… CVSS 3.1MEDIUM 6.5
- TI-2024-17441 A stored cross-site scripting (XSS) vulnerability in the Edit Content Layout module of… CVSS 3.1MEDIUM 6.1
- TI-2018-10413 An issue was discovered in Kirby 2.5.12. CVSS 3.1MEDIUM 5.4
- TI-2024-17438 Kirby CMS v4.1.0 was discovered to contain a reflected self-XSS vulnerability via the URL parameter. CVSS 3.1MEDIUM 4.7
Sources
- CVE-2023-38488 · CVE Program
- CVE-2023-38488 · NVD
- FIRST EPSS
- GHSA-x5mr-p6v4-wp93 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences