Read the docs
TI-2023-19869 Aliases CVE-2023-38489GHSA-5mvj-rvp8-rf45

Kirby vulnerable to Insufficient Session Expiration after a password change

Priority LOW 36CWE-613Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-613.

Summary

Kirby is a content management system. A vulnerability in versions prior to 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6 affects all Kirby sites with user accounts (unless Kirby's API and Panel are disabled in the config). It can only be abused if a Kirby user is logged in on a device or browser that is shared with potentially untrusted users or if an attacker already maliciously used a previous password to log in to a Kirby site as the affected user. Insufficient Session Expiration is when a web site permits an attacker to reuse old session credentials or session IDs for authorization. In the variation described in this advisory, it allows attackers to stay logged in to a Kirby site on another device even if the logged in user has since changed their password. Kirby did not invalidate user sessions that were created with a password that was since changed by the user or by a site admin. If a user changed their password to lock out an attacker who was already in possession of the previous password or of a login session on another device or browser, the attacker would not be reliably prevented from accessing the Kirby site as the affected user. The problem has been patched in Kirby 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.4.1, and 3.9.6. In all of the mentioned releases, the maintainers have updated the authentication implementation to keep track of the hashed password in each active session. If the password changed since the login, the session is invalidated. To enforce this fix even if the vulnerability was previously abused, all users are logged out from the Kirby site after updating to one of the patched releases.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00809 57th percentileScored 2026-11-07
Fix Fixed kirby (getkirby): 3.5.8.3, 3.6.6.3, 3.7.5.2 +2getkirby/cms (Packagist): 3.5.8.3, 3.6.6.3, 3.7.5.2 +2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
getkirbykirbybefore 3.5.8.3; 3.6.0 to before 3.6.6.3; 3.7.0 to before 3.7.5.2; 3.8.0 to before 3.8.41; 3.9.0 to before 3.9.63.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.41, 3.9.6Patch availableCNA
—getkirby/cms (Packagist)before 3.5.8.33.5.8.3Patch availableGHSA-5mvj-rvp8-rf45
—getkirby/cms (Packagist)3.6.0 to before 3.6.6.33.6.6.3Patch availableGHSA-5mvj-rvp8-rf45
—getkirby/cms (Packagist)3.7.0 to before 3.7.5.23.7.5.2Patch availableGHSA-5mvj-rvp8-rf45
—getkirby/cms (Packagist)3.8.0 to before 3.8.4.13.8.4.1Patch availableGHSA-5mvj-rvp8-rf45
—getkirby/cms (Packagist)3.9.0 to before 3.9.63.9.6Patch availableGHSA-5mvj-rvp8-rf45
  • kirby Vendorgetkirby Affected before 3.5.8.3; 3.6.0 to before 3.6.6.3; 3.7.0 to before 3.7.5.2; 3.8.0 to before 3.8.41; 3.9.0 to before 3.9.6 Fixed in 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.41, 3.9.6 Patch available CNA
  • getkirby/cms (Packagist) Vendor— Affected before 3.5.8.3 Fixed in 3.5.8.3 Patch available GHSA-5mvj-rvp8-rf45
  • getkirby/cms (Packagist) Vendor— Affected 3.6.0 to before 3.6.6.3 Fixed in 3.6.6.3 Patch available GHSA-5mvj-rvp8-rf45
  • getkirby/cms (Packagist) Vendor— Affected 3.7.0 to before 3.7.5.2 Fixed in 3.7.5.2 Patch available GHSA-5mvj-rvp8-rf45
  • getkirby/cms (Packagist) Vendor— Affected 3.8.0 to before 3.8.4.1 Fixed in 3.8.4.1 Patch available GHSA-5mvj-rvp8-rf45
  • getkirby/cms (Packagist) Vendor— Affected 3.9.0 to before 3.9.6 Fixed in 3.9.6 Patch available GHSA-5mvj-rvp8-rf45

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:*3.5.0 to before 3.5.8.3; 3.6.0 to before 3.6.6.3; 3.7.0 to before 3.7.5.2; 3.8.0 to before 3.8.4.1; 3.9.0 to before 3.9.6Vulnerablegetkirby
  • cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:* Versions 3.5.0 to before 3.5.8.3; 3.6.0 to before 3.6.6.3; 3.7.0 to before 3.7.5.2; 3.8.0 to before 3.8.4.1; 3.9.0 to before 3.9.6 Vulnerable ·getkirby

Remediation

  • Fix · CNA kirby (getkirby) Fixed in 3.5.8.3, 3.6.6.3, 3.7.5.2, 3.8.41, 3.9.6
  • Fix · GHSA-5mvj-rvp8-rf45 getkirby/cms (Packagist) Fixed in 3.5.8.3 Advisory →
  • Fix · GHSA-5mvj-rvp8-rf45 getkirby/cms (Packagist) Fixed in 3.6.6.3 Advisory →
  • Fix · GHSA-5mvj-rvp8-rf45 getkirby/cms (Packagist) Fixed in 3.7.5.2 Advisory →
  • Fix · GHSA-5mvj-rvp8-rf45 getkirby/cms (Packagist) Fixed in 3.8.4.1 Advisory →
  • Fix · GHSA-5mvj-rvp8-rf45 getkirby/cms (Packagist) Fixed in 3.9.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-38489
  2. 2026-10-03 Alias added: GHSA-5mvj-rvp8-rf45

References

  • TI-2024-17440 An arbitrary file upload vulnerability in the Profile Image module of Kirby CMS v4.1.0… CVSS 3.1HIGH 8.8
  • TI-2024-17439 An HTML injection vulnerability exists in the Edit Content Layout module of Kirby CMS… CVSS 3.1HIGH 7.1
  • TI-2026-23396 Kirby CMS through 5.1.4 allows an authenticated user with 'Editor' permissions to cause a… CVSS 3.1MEDIUM 6.5
  • TI-2024-17441 A stored cross-site scripting (XSS) vulnerability in the Edit Content Layout module of… CVSS 3.1MEDIUM 6.1
  • TI-2018-10413 An issue was discovered in Kirby 2.5.12. CVSS 3.1MEDIUM 5.4
  • TI-2024-17438 Kirby CMS v4.1.0 was discovered to contain a reflected self-XSS vulnerability via the URL parameter. CVSS 3.1MEDIUM 4.7
See all 40 →

Sources