Apptainer's ineffective privileges drop when requesting container network
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- None · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-269.
Summary
Apptainer is an open source container platform. Version 1.2.0-rc.2 introduced an ineffective privilege drop when requesting container network setup, therefore subsequent functions are called with root privileges, the attack surface is rather limited for users but an attacker could possibly craft a starter config to delete any directory on the host filesystems. A security fix has been included in Apptainer 1.2.1. There is no known workaround outside of upgrading to Apptainer 1.2.1.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| MLflow | apptainer | 1.2.0-rc.2 to before 1.2.1 | 1.2.1 | Patch available | CNA |
| — | github.com/apptainer/apptainer (Go) | 1.2.0 to before 1.2.1 | 1.2.1 | Patch available | GHSA-mmx5-32m4-wxvx |
- apptainer VendorMLflow Affected 1.2.0-rc.2 to before 1.2.1 Fixed in 1.2.1 Patch available CNA
- github.com/apptainer/apptainer (Go) Vendor— Affected 1.2.0 to before 1.2.1 Fixed in 1.2.1 Patch available GHSA-mmx5-32m4-wxvx
Remediation
- Fix · CNA apptainer (apptainer) Fixed in 1.2.1
- Fix · GHSA-mmx5-32m4-wxvx github.com/apptainer/apptainer (Go) Fixed in 1.2.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-38496
- 2026-10-03 Alias added: GHSA-mmx5-32m4-wxvx
References
More MLflow Apptainer vulnerabilities
- TI-2023-14384 Unpatched extfs vulnerabilities are exploitable through suid-mode Apptainer CVSS 3.1HIGH 7.8
- TI-2025-40257 Apptainer ineffective application of selinux and apparmor --security options CVSS 3.1MEDIUM 5.3
Sources
- CVE-2023-38496 · CVE Program
- CVE-2023-38496 · NVD
- FIRST EPSS
- GHSA-mmx5-32m4-wxvx · GitHub Advisory Database · CC BY 4.0
- CVE-2023-38496 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences