Read the docs
TI-2023-19884 Aliases CVE-2023-38504GHSA-gpw9-fwm8-7rx7

Sails DoS vulnerability for apps with sockets enabled

Priority MEDIUM 41CWE-248Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-248.

Summary

Sails is a realtime MVC Framework for Node.js. In Sails apps prior to version 1.5.7,, an attacker can send a virtual request that will cause the node process to crash. This behavior was fixed in Sails v1.5.7. As a workaround, disable the sockets hook and remove the `sails.io.js` client.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00937 61st percentileScored 2026-11-07
Fix Fixed sails (balderdashy): 1.5.7sails (npm): 1.5.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
balderdashysailsbefore 1.5.71.5.7Patch availableCNA
—sails (npm)before 1.5.71.5.7Patch availableGHSA-gpw9-fwm8-7rx7
  • sails Vendorbalderdashy Affected before 1.5.7 Fixed in 1.5.7 Patch available CNA
  • sails (npm) Vendor— Affected before 1.5.7 Fixed in 1.5.7 Patch available GHSA-gpw9-fwm8-7rx7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:sailsjs:sails:*:*:*:*:*:node.js:*:*before 1.5.7VulnerableSailsjs
  • cpe:2.3:a:sailsjs:sails:*:*:*:*:*:node.js:*:* Versions before 1.5.7 Vulnerable ·Sailsjs

Remediation

  • Fix · CNA sails (balderdashy) Fixed in 1.5.7
  • Fix · GHSA-gpw9-fwm8-7rx7 sails (npm) Fixed in 1.5.7 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-38504
  2. 2026-10-03 Alias added: GHSA-gpw9-fwm8-7rx7

References

  • TI-2021-20324 SailsJS Sails.js <=1.4.0 is vulnerable to Prototype Pollution via… CVSS 3.1CRITICAL 9.8
  • TI-2018-14998 Sails.js before v1.0.0-46 allows attackers to cause a denial of service with a single… CVSS 3.1HIGH 7.5
  • TI-2016-08590 Improper access control in HackerOne sails node module CVSS 3.0MEDIUM 4.4

Sources