Cross Site Scripting vulnerability in Spipu HTML2PDF before v.5.2.8 allows a remote…
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross Site Scripting vulnerability in Spipu HTML2PDF before v.5.2.8 allows a remote attacker to execute arbitrary code via a crafted script to the forms.php.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01464 73rd percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed spipu/html2pdf (Packagist): 5.2.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | spipu/html2pdf (Packagist) | before 5.2.8 | 5.2.8 | Patch available | GHSA-99fg-2h75-m92h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- spipu/html2pdf (Packagist) Vendor— Affected before 5.2.8 Fixed in 5.2.8 Patch available GHSA-99fg-2h75-m92h
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:html2pdf_project:html2pdf:*:*:*:*:*:*:*:* | before 5.2.8 | Vulnerable | Html2pdf Project |
- cpe:2.3:a:html2pdf_project:html2pdf:*:*:*:*:*:*:*:* Versions before 5.2.8 Vulnerable ·Html2pdf Project
Remediation
- Fix · GHSA-99fg-2h75-m92h spipu/html2pdf (Packagist) Fixed in 5.2.8 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-39062
- 2026-10-03 Alias added: GHSA-99fg-2h75-m92h
References
Exploit 2
More Html2pdf Project Html2pdf vulnerabilities
- TI-2021-20510 An issue was discovered in Spipu HTML2PDF before 5.2.4. CVSS 3.1HIGH 8.8
Sources
- CVE-2023-39062 · CVE Program
- CVE-2023-39062 · NVD
- FIRST EPSS
- GHSA-99fg-2h75-m92h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences