Improper input validation in Dell CPG BIOS
Priority LOW 29CWE-20Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
Dell BIOS contains an Improper Input Validation vulnerability. A local malicious user with high privileges could potentially exploit this vulnerability in order to corrupt memory on the system.
Why it matters now
EPSS 0.00167 5th percentileScored 2026-11-07
Fix Fixed CPG BIOS (Dell): 1.20.0, 1.23.0, 1.27.0 +2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | CPG BIOS | before 1.20.0; before 1.23.0; before 1.27.0; before 1.25.0; before 1.24.0 | 1.20.0, 1.23.0, 1.27.0, 1.25.0, 1.24.0 | Patch available | CNA |
- CPG BIOS VendorDell Affected before 1.20.0; before 1.23.0; before 1.27.0; before 1.25.0; before 1.24.0 Fixed in 1.20.0, 1.23.0, 1.27.0, 1.25.0, 1.24.0 Patch available CNA
CPE configurations NVD · 26
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:inspiron_7510_firmware:*:*:*:*:*:*:*:* | before 1.20.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:inspiron_7510:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:inspiron_7610_firmware:*:*:*:*:*:*:*:* | before 1.20.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:inspiron_7610:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:latitude_5430_rugged_firmware:*:*:*:*:*:*:*:* | before 1.23.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitude_5430_rugged:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:latitude_5521_firmware:*:*:*:*:*:*:*:* | before 1.27.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitude_5521:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:latitude_7330_rugged_firmware:*:*:*:*:*:*:*:* | before 1.23.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:latitude_7330_rugged:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:inspiron_7510_firmware:*:*:*:*:*:*:*:* Versions before 1.20.0 Vulnerable ·Dell
- cpe:2.3:h:dell:inspiron_7510:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:inspiron_7610_firmware:*:*:*:*:*:*:*:* Versions before 1.20.0 Vulnerable ·Dell
- cpe:2.3:h:dell:inspiron_7610:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:latitude_5430_rugged_firmware:*:*:*:*:*:*:*:* Versions before 1.23.0 Vulnerable ·Dell
- cpe:2.3:h:dell:latitude_5430_rugged:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:latitude_5521_firmware:*:*:*:*:*:*:*:* Versions before 1.27.0 Vulnerable ·Dell
- cpe:2.3:h:dell:latitude_5521:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:latitude_7330_rugged_firmware:*:*:*:*:*:*:*:* Versions before 1.23.0 Vulnerable ·Dell
- cpe:2.3:h:dell:latitude_7330_rugged:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Show 16 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:dell:precision_3561_firmware:*:*:*:*:*:*:*:* | before 1.27.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:precision_3561:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:precision_5560_firmware:*:*:*:*:*:*:*:* | before 1.25.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:precision_5560:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:precision_5760_firmware:*:*:*:*:*:*:*:* | before 1.24.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:precision_5760:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:precision_7560_firmware:*:*:*:*:*:*:*:* | before 1.27.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:precision_7560:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:precision_7760_firmware:*:*:*:*:*:*:*:* | before 1.27.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:precision_7760:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:vostro_7510_firmware:*:*:*:*:*:*:*:* | before 1.20.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:vostro_7510:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:xps_15_9510_firmware:*:*:*:*:*:*:*:* | before 1.25.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:xps_15_9510:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
| cpe:2.3:o:dell:xps_17_9710_firmware:*:*:*:*:*:*:*:* | before 1.24.0 | Vulnerable | Dell |
| cpe:2.3:h:dell:xps_17_9710:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Dell |
- cpe:2.3:o:dell:precision_3561_firmware:*:*:*:*:*:*:*:* Versions before 1.27.0 Vulnerable ·Dell
- cpe:2.3:h:dell:precision_3561:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:precision_5560_firmware:*:*:*:*:*:*:*:* Versions before 1.25.0 Vulnerable ·Dell
- cpe:2.3:h:dell:precision_5560:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:precision_5760_firmware:*:*:*:*:*:*:*:* Versions before 1.24.0 Vulnerable ·Dell
- cpe:2.3:h:dell:precision_5760:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:precision_7560_firmware:*:*:*:*:*:*:*:* Versions before 1.27.0 Vulnerable ·Dell
- cpe:2.3:h:dell:precision_7560:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:precision_7760_firmware:*:*:*:*:*:*:*:* Versions before 1.27.0 Vulnerable ·Dell
- cpe:2.3:h:dell:precision_7760:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:vostro_7510_firmware:*:*:*:*:*:*:*:* Versions before 1.20.0 Vulnerable ·Dell
- cpe:2.3:h:dell:vostro_7510:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:xps_15_9510_firmware:*:*:*:*:*:*:*:* Versions before 1.25.0 Vulnerable ·Dell
- cpe:2.3:h:dell:xps_15_9510:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
- cpe:2.3:o:dell:xps_17_9710_firmware:*:*:*:*:*:*:*:* Versions before 1.24.0 Vulnerable ·Dell
- cpe:2.3:h:dell:xps_17_9710:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Dell
Remediation
- Fix · CNA CPG BIOS (Dell) Fixed in 1.20.0, 1.23.0, 1.27.0, 1.25.0, 1.24.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-39251
- 2026-10-03 Alias added: GHSA-jh5h-57c3-2c78
References
More Dell Inspiron 7510 Firmware vulnerabilities
- TI-2022-15301 Stack-based buffer overflow in Dell CPG BIOS CVSS 3.1HIGH 8.8
- TI-2022-10105 Dell BIOS versions contain an Insecure Automated Optimization vulnerability. CVSS 3.1HIGH 7.9
- TI-2022-10104 Stack-based buffer overflow in Dell CPG BIOS CVSS 3.1HIGH 7.8
- TI-2022-15298 Heap-based buffer overflow in Dell CPG BIOS CVSS 3.1HIGH 7.1
- TI-2022-10102 Improper authentication in Dell CPG BIOS CVSS 3.1HIGH 7.8
- TI-2023-15762 Improper input validation in Dell CPG BIOS CVSS 3.1MEDIUM 6.8
Sources
- CVE-2023-39251 · CVE Program
- CVE-2023-39251 · NVD
- FIRST EPSS
- GHSA-jh5h-57c3-2c78 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences