Read the docs
TI-2023-20659 Aliases CVE-2023-39527GHSA-xw2r-f8xv-c8xp

PrestaShop XSS vulnerability through Validate::isCleanHTML method

Priority LOW 37CWE-116Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

PrestaShop is an open source e-commerce web application. Versions prior to 1.7.8.10, 8.0.5, and 8.1.1 are vulnerable to cross-site scripting through the `isCleanHTML` method. Versions 1.7.8.10, 8.0.5, and 8.1.1 contain a patch. There are no known workarounds.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00513 44th percentileScored 2026-11-07
Fix Fixed PrestaShop (PrestaShop): 1.7.8.10, 8.0.5prestashop/prestashop (Packagist): 8.1.1, 8.0.5, 1.7.8.10

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PrestaShopPrestaShopbefore 1.7.8.10; 8.0.0 to before 8.0.5; = 8.1.01.7.8.10, 8.0.5Patch availableCNA
—prestashop/prestashop (Packagist)8.1.0 to before 8.1.18.1.1Patch availableGHSA-xw2r-f8xv-c8xp
—prestashop/prestashop (Packagist)8.0.0 to before 8.0.58.0.5Patch availableGHSA-xw2r-f8xv-c8xp
—prestashop/prestashop (Packagist)before 1.7.8.101.7.8.10Patch availableGHSA-xw2r-f8xv-c8xp
  • PrestaShop VendorPrestaShop Affected before 1.7.8.10; 8.0.0 to before 8.0.5; = 8.1.0 Fixed in 1.7.8.10, 8.0.5 Patch available CNA
  • prestashop/prestashop (Packagist) Vendor— Affected 8.1.0 to before 8.1.1 Fixed in 8.1.1 Patch available GHSA-xw2r-f8xv-c8xp
  • prestashop/prestashop (Packagist) Vendor— Affected 8.0.0 to before 8.0.5 Fixed in 8.0.5 Patch available GHSA-xw2r-f8xv-c8xp
  • prestashop/prestashop (Packagist) Vendor— Affected before 1.7.8.10 Fixed in 1.7.8.10 Patch available GHSA-xw2r-f8xv-c8xp

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:*before 1.7.8.10; 8.0.0 to before 8.0.5VulnerablePrestaShop
cpe:2.3:a:prestashop:prestashop:8.1.0:*:*:*:*:*:*:*8.1.0VulnerablePrestaShop
  • cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:* Versions before 1.7.8.10; 8.0.0 to before 8.0.5 Vulnerable ·PrestaShop
  • cpe:2.3:a:prestashop:prestashop:8.1.0:*:*:*:*:*:*:* Versions 8.1.0 Vulnerable ·PrestaShop

Remediation

  • Fix · CNA PrestaShop (PrestaShop) Fixed in 1.7.8.10, 8.0.5
  • Fix · GHSA-xw2r-f8xv-c8xp prestashop/prestashop (Packagist) Fixed in 8.1.1 Advisory →
  • Fix · GHSA-xw2r-f8xv-c8xp prestashop/prestashop (Packagist) Fixed in 8.0.5 Advisory →
  • Fix · GHSA-xw2r-f8xv-c8xp prestashop/prestashop (Packagist) Fixed in 1.7.8.10 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-39527
  2. 2026-10-03 Alias added: GHSA-xw2r-f8xv-c8xp

References

  • TI-2024-27717 An issue in Prestashop v.8.1.7 and before allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
  • TI-2024-23013 PrestaShop vulnerable to XSS via customer contact form in FO, through file upload CVSS 3.1CRITICAL 9.7
  • TI-2018-06367 modules/bamegamenu/ajax_phpcode.php in the Responsive Mega Menu… CVSS 3.0CRITICAL 9.8
  • TI-2025-19098 A PHAR deserialization vulnerability in the _getHeaders function of PrestaShop v8.2.0… CVSS 3.1MEDIUM 6.5
  • TI-2018-13560 PrestaShop 1.6.x before 1.6.1.23 and 1.7.x before 1.7.4.4 allows remote attackers to… CVSS 3.0CRITICAL 9.8
  • TI-2021-02206 The store system in PrestaShop 1.7.7.0 allows time-based boolean SQL injection via the… CVSS 3.1CRITICAL 9.8
See all 92 →

Sources