PrestaShop vulnerable to file deletion via attachment API
Priority MEDIUM 40CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
PrestaShop is an open source e-commerce web application. Prior to version 8.1.1, it is possible to delete a file from the server by using the Attachments controller and the Attachments API. Version 8.1.1 contains a patch for this issue. There are no known workarounds.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00713 53rd percentileScored 2026-11-07
Fix Fixed PrestaShop (PrestaShop): 8.1.1prestashop/prestashop (Packagist): 8.1.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PrestaShop | PrestaShop | before 8.1.1 | 8.1.1 | Patch available | CNA |
| — | prestashop/prestashop (Packagist) | before 8.1.1 | 8.1.1 | Patch available | GHSA-2rf5-3fw8-qm47 |
- PrestaShop VendorPrestaShop Affected before 8.1.1 Fixed in 8.1.1 Patch available CNA
- prestashop/prestashop (Packagist) Vendor— Affected before 8.1.1 Fixed in 8.1.1 Patch available GHSA-2rf5-3fw8-qm47
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:* | before 8.1.1 | Vulnerable | PrestaShop |
- cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:* Versions before 8.1.1 Vulnerable ·PrestaShop
Remediation
- Fix · CNA PrestaShop (PrestaShop) Fixed in 8.1.1
- Fix · GHSA-2rf5-3fw8-qm47 prestashop/prestashop (Packagist) Fixed in 8.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-39529
- 2026-10-03 Alias added: GHSA-2rf5-3fw8-qm47
References
More Prestashop vulnerabilities
- TI-2024-27717 An issue in Prestashop v.8.1.7 and before allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2024-23013 PrestaShop vulnerable to XSS via customer contact form in FO, through file upload CVSS 3.1CRITICAL 9.7
- TI-2018-06367 modules/bamegamenu/ajax_phpcode.php in the Responsive Mega Menu… CVSS 3.0CRITICAL 9.8
- TI-2025-19098 A PHAR deserialization vulnerability in the _getHeaders function of PrestaShop v8.2.0… CVSS 3.1MEDIUM 6.5
- TI-2018-13560 PrestaShop 1.6.x before 1.6.1.23 and 1.7.x before 1.7.4.4 allows remote attackers to… CVSS 3.0CRITICAL 9.8
- TI-2021-02206 The store system in PrestaShop 1.7.7.0 allows time-based boolean SQL injection via the… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-39529 · CVE Program
- CVE-2023-39529 · NVD
- FIRST EPSS
- GHSA-2rf5-3fw8-qm47 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences