Read the docs
TI-2023-20662 Aliases CVE-2023-39530GHSA-v4gr-v679-42p7

PrestaShop vulnerable to file deletion via CustomerMessage

Priority MEDIUM 41CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

PrestaShop is an open source e-commerce web application. Prior to version 8.1.1, it is possible to delete files from the server via the CustomerMessage API. Version 8.1.1 contains a patch for this issue. There are no known workarounds.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00856 58th percentileScored 2026-11-07
Fix Fixed PrestaShop (PrestaShop): 8.1.1prestashop/prestashop (Packagist): 8.1.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PrestaShopPrestaShopbefore 8.1.18.1.1Patch availableCNA
—prestashop/prestashop (Packagist)before 8.1.18.1.1Patch availableGHSA-v4gr-v679-42p7
  • PrestaShop VendorPrestaShop Affected before 8.1.1 Fixed in 8.1.1 Patch available CNA
  • prestashop/prestashop (Packagist) Vendor— Affected before 8.1.1 Fixed in 8.1.1 Patch available GHSA-v4gr-v679-42p7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:*before 8.1.1VulnerablePrestaShop
  • cpe:2.3:a:prestashop:prestashop:*:*:*:*:*:*:*:* Versions before 8.1.1 Vulnerable ·PrestaShop

Remediation

  • Fix · CNA PrestaShop (PrestaShop) Fixed in 8.1.1
  • Fix · GHSA-v4gr-v679-42p7 prestashop/prestashop (Packagist) Fixed in 8.1.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-39530
  2. 2026-10-03 Alias added: GHSA-v4gr-v679-42p7

References

  • TI-2024-27717 An issue in Prestashop v.8.1.7 and before allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
  • TI-2024-23013 PrestaShop vulnerable to XSS via customer contact form in FO, through file upload CVSS 3.1CRITICAL 9.7
  • TI-2018-06367 modules/bamegamenu/ajax_phpcode.php in the Responsive Mega Menu… CVSS 3.0CRITICAL 9.8
  • TI-2025-19098 A PHAR deserialization vulnerability in the _getHeaders function of PrestaShop v8.2.0… CVSS 3.1MEDIUM 6.5
  • TI-2018-13560 PrestaShop 1.6.x before 1.6.1.23 and 1.7.x before 1.7.4.4 allows remote attackers to… CVSS 3.0CRITICAL 9.8
  • TI-2021-02206 The store system in PrestaShop 1.7.7.0 allows time-based boolean SQL injection via the… CVSS 3.1CRITICAL 9.8
See all 92 →

Sources