An issue in Gaberiele Venturi pandasai v.0.8.0 and before allows a remote attacker to…
Priority HIGH 82CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
An issue in Gaberiele Venturi pandasai v.0.8.0 and before allows a remote attacker to execute arbitrary code via a crafted request to the prompt function.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01534 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed pandasai (PyPI): 0.8.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pandasai (PyPI) | before 0.8.1 | 0.8.1 | Patch available | GHSA-w832-v3c6-m6rg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pandasai (PyPI) Vendor— Affected before 0.8.1 Fixed in 0.8.1 Patch available GHSA-w832-v3c6-m6rg
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gabrieleventuri:pandasai:*:*:*:*:*:python:*:* | up to 0.8.0 | Vulnerable | Gabrieleventuri |
- cpe:2.3:a:gabrieleventuri:pandasai:*:*:*:*:*:python:*:* Versions up to 0.8.0 Vulnerable ·Gabrieleventuri
Remediation
- Fix · GHSA-w832-v3c6-m6rg pandasai (PyPI) Fixed in 0.8.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-39660
- 2026-10-03 Alias added: GHSA-w832-v3c6-m6rg
References
More Gabrieleventuri Pandasai vulnerabilities
- TI-2024-15755 GenerateSDFPipeline in synthetic_dataframe in PandasAI (aka pandas-ai) through 1.5.17… CVSS 3.1CRITICAL 9.8
- TI-2023-20726 An issue in pandas-ai v.0.9.1 and before allows a remote attacker to execute arbitrary… CVSS 3.1CRITICAL 9.8
- TI-2026-23484 pandas-ai v3.0.0 was discovered to contain a SQL injection vulnerability via the… CVSS 3.1HIGH 7.3
Sources
- CVE-2023-39660 · CVE Program
- CVE-2023-39660 · NVD
- FIRST EPSS
- GHSA-w832-v3c6-m6rg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences