Read the docs
TI-2023-20838 Aliases CVE-2023-39945

Malformed serialized data in a data submessage leads to unhandled exception

Priority HIGH 75CWE-248Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
Low · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-248.

Summary

eprosima Fast DDS is a C++ implementation of the Data Distribution Service standard of the Object Management Group. Prior to versions 2.11.0, 2.10.2, 2.9.2, and 2.6.5, a data submessage sent to PDP port raises unhandled `BadParamException` in fastcdr, which in turn crashes fastdds. Versions 2.11.0, 2.10.2, 2.9.2, and 2.6.5 contain a patch for this issue.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00939 61st percentileScored 2026-11-07
Fix Fixed Fast-DDS (eProsima): 2.6.5, 2.9.2, 2.10.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
eProsimaFast-DDSbefore 2.6.5; 2.7.0 to before 2.9.2; 2.10.0 to before 2.10.22.6.5, 2.9.2, 2.10.2Patch availableCNA
  • Fast-DDS VendoreProsima Affected before 2.6.5; 2.7.0 to before 2.9.2; 2.10.0 to before 2.10.2 Fixed in 2.6.5, 2.9.2, 2.10.2 Patch available CNA

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:eprosima:fast_dds:*:*:*:*:*:*:*:*2.6.0 to before 2.6.5; 2.9.0 to before 2.9.2; 2.10.0 to before 2.10.2VulnerableeProsima
cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*11.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:*12.0VulnerableDebian
  • cpe:2.3:a:eprosima:fast_dds:*:*:*:*:*:*:*:* Versions 2.6.0 to before 2.6.5; 2.9.0 to before 2.9.2; 2.10.0 to before 2.10.2 Vulnerable ·eProsima
  • cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:* Versions 12.0 Vulnerable ·Debian

Remediation

  • Fix · CNA Fast-DDS (eProsima) Fixed in 2.6.5, 2.9.2, 2.10.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-39945

References

  • TI-2025-38815 Integer overflow in eProsima Fast-DDS CVSS 3.1HIGH 8.6
  • TI-2024-18790 Manipulated DATA Submessage causes a heap-buffer-overflow error CVSS 3.1CRITICAL 9.7
  • TI-2023-27485 Disconnect Vulnerability in RTPS Packets Used by SROS2 CVSS 3.1CRITICAL 9.7
  • TI-2024-20005 FastDDS heap buffer overflow when publisher sends malformed packet CVSS 3.1HIGH 8.2
  • TI-2023-20840 Another heap overflow in push_back_helper CVSS 3.1HIGH 8.2
  • TI-2023-20839 Heap overflow in push_back_helper due to a CDR message CVSS 3.1HIGH 8.2
See all 26 →

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences