@node-saml/node-saml's validatePostRequestAsync does not include checkTimestampsValidityError
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-347.
Summary
Node-SAML is a SAML library not dependent on any frameworks that runs in Node. The lack of checking of current timestamp allows a LogoutRequest XML to be reused multiple times even when the current time is past the NotOnOrAfter. This could impact the user where they would be logged out from an expired LogoutRequest. In bigger contexts, if LogoutRequests are sent out in mass to different SPs, this could impact many users on a large scale. This issue was patched in version 4.0.5.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| node-saml | node-saml | before 4.0.5 | 4.0.5 | Patch available | CNA |
| — | @node-saml/node-saml (npm) | before 4.0.5 | 4.0.5 | Patch available | GHSA-vx8m-6fhw-pccw |
- node-saml Vendornode-saml Affected before 4.0.5 Fixed in 4.0.5 Patch available CNA
- @node-saml/node-saml (npm) Vendor— Affected before 4.0.5 Fixed in 4.0.5 Patch available GHSA-vx8m-6fhw-pccw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:node_saml_project:node_saml:*:*:*:*:*:node.js:*:* | before 4.0.5 | Vulnerable | Node Saml Project |
- cpe:2.3:a:node_saml_project:node_saml:*:*:*:*:*:node.js:*:* Versions before 4.0.5 Vulnerable ·Node Saml Project
Remediation
- Fix · CNA node-saml (node-saml) Fixed in 4.0.5
- Fix · GHSA-vx8m-6fhw-pccw @node-saml/node-saml (npm) Fixed in 4.0.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-40178
- 2026-10-03 Alias added: GHSA-vx8m-6fhw-pccw
References
Advisory 2
More node-saml vulnerabilities
- TI-2024-21829 XML signature verification bypass due improper verification of signature / signature spoofing CVSS 3.1CRITICAL 10.0
- TI-2025-21187 xml-crypto Vulnerable to XML Signature Verification Bypass via DigestValue Comment CVSS 4.0CRITICAL 9.3
- TI-2025-21186 xml-crypto Vulnerable to XML Signature Verification Bypass via Multiple SignedInfo References CVSS 4.0CRITICAL 9.3
- TI-2025-34225 Node-SAML Contains SAML Signature Verification Vulnerability CVSS 3.1CRITICAL 10.0
- TI-2025-34181 Node-SAML SAML Authentication Bypass CVSS 4.0CRITICAL 9.3
Sources
- CVE-2023-40178 · CVE Program
- CVE-2023-40178 · NVD
- FIRST EPSS
- GHSA-vx8m-6fhw-pccw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences