Jenkins NodeJS Plugin 1.6.0 and earlier does not properly mask (i.e., replace with…
Priority MEDIUM 40Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Jenkins NodeJS Plugin 1.6.0 and earlier does not properly mask (i.e., replace with asterisks) credentials specified in the Npm config file in Pipeline build logs.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00633 50th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:nodejs (Maven): 1.6.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins NodeJS Plugin | up to 1.6.0 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:nodejs (Maven) | before 1.6.1 | 1.6.1 | Patch available | GHSA-36fg-whr2-g999 |
- Jenkins NodeJS Plugin VendorJenkins Affected up to 1.6.0 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:nodejs (Maven) Vendor— Affected before 1.6.1 Fixed in 1.6.1 Patch available GHSA-36fg-whr2-g999
Remediation
- Fix · GHSA-36fg-whr2-g999 org.jenkins-ci.plugins:nodejs (Maven) Fixed in 1.6.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-40340
- 2026-10-03 Alias added: GHSA-36fg-whr2-g999
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
Sources
- CVE-2023-40340 · CVE Program
- CVE-2023-40340 · NVD
- FIRST EPSS
- GHSA-36fg-whr2-g999 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences