Missing authorization in Jenkins Delphix Plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
A missing permission check in Jenkins Delphix Plugin 3.0.2 and earlier allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Delphix Plugin | up to 3.0.2 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:delphix (Maven) | before 3.0.3 | 3.0.3 | Patch available | GHSA-3fqw-j7x8-g75j |
- Jenkins Delphix Plugin VendorJenkins Affected up to 3.0.2 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:delphix (Maven) Vendor— Affected before 3.0.3 Fixed in 3.0.3 Patch available GHSA-3fqw-j7x8-g75j
Remediation
- Fix · GHSA-3fqw-j7x8-g75j org.jenkins-ci.plugins:delphix (Maven) Fixed in 3.0.3 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Jenkins Delphix Plugin — Jenkins Security Advisory 2023-08-16
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2023-21174 Insufficiently protected credentials in Jenkins Delphix PluginPriority LOW 31
Timeline
- 2026-10-02 Threatist record created from CVE-2023-40344
- 2026-10-03 Alias added: GHSA-3fqw-j7x8-g75j
- 2026-10-14 EPSS moved to the 50th–90th percentile
References
Advisory 3
More Jenkins Delphix vulnerabilities
- TI-2019-07762 Cleartext storage of sensitive information in Jenkins Delphix Plugin CVSS 3.1HIGH 7.8
- TI-2023-21174 Insufficiently protected credentials in Jenkins Delphix Plugin CVSS 3.1MEDIUM 6.5
- TI-2024-18739 Improper certificate validation in Jenkins Delphix Plugin CVSS 3.1MEDIUM 5.3
- TI-2024-18740 Improper certificate validation in Jenkins Delphix Plugin CVSS 3.1MEDIUM 4.2
Sources
- CVE-2023-40344 · CVE Program
- CVE-2023-40344 · NVD
- FIRST EPSS
- GHSA-3fqw-j7x8-g75j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences