Opensc: multiple memory issues with pkcs15-init (enrollment tool)
Key facts
- Attack vector
- Physical
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-119 and the CVSS impact.
Summary
Several memory vulnerabilities were identified within the OpenSC packages, particularly in the card enrollment process using pkcs15-init when a user or administrator enrolls cards. To take advantage of these flaws, an attacker must have physical access to the computer system and employ a custom-crafted USB device or smart card to manipulate responses to APDUs. This manipulation can potentially allow compromise key generation, certificate loading, and other card management operations during enrollment.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | OpenSC | before 0.24.0 | 0.24.0 | Patch available | CNA |
| Red Hat | Red Hat Enterprise Linux 8 | — | 0.20.0-7.el8_9 | Patch available | CNA |
| Red Hat | Red Hat Enterprise Linux 9 | — | 0.23.0-3.el9_3 | Patch available | CNA |
| Red Hat | Red Hat Enterprise Linux 7 | — | — | No fix listed | CNA |
- OpenSC Vendor— Affected before 0.24.0 Fixed in 0.24.0 Patch available CNA
- Red Hat Enterprise Linux 8 VendorRed Hat Affected — Fixed in 0.20.0-7.el8_9 Patch available CNA
- Red Hat Enterprise Linux 9 VendorRed Hat Affected — Fixed in 0.23.0-3.el9_3 Patch available CNA
- Red Hat Enterprise Linux 7 VendorRed Hat Affected — Fixed in — No fix listed CNA
Remediation
- Fix · CNA OpenSC Fixed in 0.24.0
Red Hat 2 advisories
- RHSA-2023:7876 Released 2023-12-19 · Red Hat rating Moderateopensc security update
- Red Hat Enterprise Linux BaseOS (v. 8) opensc-0.20.0-7.el8_9
- RHSA-2023:7879 Released 2023-12-19 · Red Hat rating Moderateopensc security update
- Red Hat Enterprise Linux BaseOS (v. 9) opensc-0.23.0-3.el9_3
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9 — RHSA-2023:7879
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2023-21453 Opensc: potential pin bypass when card tracks its own login statePriority LOW 33
- TI-2023-04181 Opensc: out-of-bounds read in myeid driver handling encryption using symmetric keysPriority LOW 21
- Advisory ·
Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8, Red Hat Enterprise Linux 9 — RHSA-2023:7876
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2023-21453 Opensc: potential pin bypass when card tracks its own login statePriority LOW 33
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux BaseOS (v. 8) | Fixed | RHSA-2023:7876 |
| Red Hat Enterprise Linux BaseOS (v. 9) | Fixed | RHSA-2023:7879 |
Timeline
- 2026-10-02 Threatist record created from CVE-2023-40661
- 2026-10-03 Alias added: GHSA-2c2j-2pgv-gfgc
References
More Red Hat Enterprise Linux vulnerabilities
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2018-10530 Code injection in [UNKNOWN] RichFaces KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2025-23530 Sudo before 1.9.17p1 allows local users to obtain root access because /etc/nsswitch.conf… KEVCVSS 3.1CRITICAL 9.3
- TI-2021-17490 mod_proxy SSRF KEVCVSS 3.1CRITICAL 9.0
Sources
- CVE-2023-40661 · CVE Program
- CVE-2023-40661 · NVD
- FIRST EPSS
- GHSA-2c2j-2pgv-gfgc · GitHub Advisory Database · CC BY 4.0
- CVE-2023-40661 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences