Read the docs
TI-2023-21683 Aliases CVE-2023-41057GHSA-xc27-f9q3-4448

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in hyper-bump-it

Priority LOW 25CWE-22Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

hyper-bump-it is a command line tool for updating the version in project files.`hyper-bump-it` reads a file glob pattern from the configuration file. That is combined with the project root directory to construct a full glob pattern that is used to find files that should be edited. These matched files should be contained within the project root directory, but that is not checked. This could result in changes being written to files outside of the project. The default behaviour of `hyper-bump-it` is to display the planned changes and prompt the user for confirmation before editing any files. However, the configuration file provides a field that can be used cause files to be edited without displaying the prompt. This issue has been fixed in release version 0.5.1. Users are advised to upgrade. Users that are unable to update from vulnerable versions, executing `hyper-bump-it` with the `--interactive` command line argument will ensure that all planned changes are displayed and prompt the user for confirmation before editing any files, even if the configuration file contains `show_confirm_prompt=true`.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00365 30th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed hyper-bump-it (plannigan): 0.5.1hyper-bump-it (PyPI): 0.5.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
planniganhyper-bump-itbefore 0.5.10.5.1Patch availableCNA
—hyper-bump-it (PyPI)before 0.5.10.5.1Patch availableGHSA-xc27-f9q3-4448
  • hyper-bump-it Vendorplannigan Affected before 0.5.1 Fixed in 0.5.1 Patch available CNA
  • hyper-bump-it (PyPI) Vendor— Affected before 0.5.1 Fixed in 0.5.1 Patch available GHSA-xc27-f9q3-4448

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:plannigan:hyper_bump_it:*:*:*:*:*:python:*:*before 0.5.1Vulnerableplannigan
  • cpe:2.3:a:plannigan:hyper_bump_it:*:*:*:*:*:python:*:* Versions before 0.5.1 Vulnerable ·plannigan

Remediation

  • Fix · CNA hyper-bump-it (plannigan) Fixed in 0.5.1
  • Fix · GHSA-xc27-f9q3-4448 hyper-bump-it (PyPI) Fixed in 0.5.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-41057
  2. 2026-10-03 Alias added: GHSA-xc27-f9q3-4448

References

Sources