An issue was discovered in the captive portal in OpenNDS before version 10.1.3.
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-787 and the CVSS impact.
Summary
An issue was discovered in the captive portal in OpenNDS before version 10.1.3. get_query in http_microhttpd.c does not validate the length of the query string of GET requests. This leads to a stack-based buffer overflow in versions 9.x and earlier, and to a heap-based buffer overflow in versions 10.x and later. Attackers may exploit the issue to crash OpenNDS (Denial-of-Service condition) or to inject and execute arbitrary bytecode (Remote Code Execution). Affected OpenNDS before version 10.1.3 fixed in OpenWrt master and OpenWrt 23.05 on 23. November by updating OpenNDS to version 10.2.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-41101
- 2026-10-03 Alias added: GHSA-75j8-mr4c-4x59
References
More Opennds vulnerabilities
- TI-2023-19721 An issue was discovered in OpenNDS before 10.1.3. CVSS 3.1CRITICAL 9.8
- TI-2023-19715 An issue was discovered in OpenNDS before 10.1.3. CVSS 3.1CRITICAL 9.8
- TI-2023-19717 An issue was discovered in OpenNDS before 10.1.3. CVSS 3.1CRITICAL 9.8
- TI-2023-19716 An issue was discovered in OpenNDS before 10.1.3. CVSS 3.1CRITICAL 9.8
- TI-2023-21724 An issue was discovered in the captive portal in OpenNDS before version 10.1.3. CVSS 3.1HIGH 7.5
- TI-2024-16946 openNDS 10.2.0 is vulnerable to Use-After-Free via /openNDS/src/auth.c. CVSS 3.1MEDIUM 5.5
Sources
- CVE-2023-41101 · CVE Program
- CVE-2023-41101 · NVD
- FIRST EPSS
- GHSA-75j8-mr4c-4x59 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences