Apache HDFS Provider error message suggested installation of incorrect pip package
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-829.
Summary
In the Apache Airflow HDFS Provider, versions prior to 4.1.1, a documentation info pointed users to an install incorrect pip package. As this package name was unclaimed, in theory, an attacker could claim this package and provide code that would be executed when this package was installed. The Airflow team has since taken ownership of the package (neutralizing the risk), and fixed the doc strings in version 4.1.1
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Airflow HDFS Provider | before 4.1.1 | 4.1.1 | Patch available | CNA |
| — | apache-airflow-providers-apache-hdfs (PyPI) | before 4.1.1 | 4.1.1 | Patch available | GHSA-5hj9-m76g-xrc8 |
- Apache Airflow HDFS Provider VendorApache Affected before 4.1.1 Fixed in 4.1.1 Patch available CNA
- apache-airflow-providers-apache-hdfs (PyPI) Vendor— Affected before 4.1.1 Fixed in 4.1.1 Patch available GHSA-5hj9-m76g-xrc8
Remediation
- Fix · CNA Apache Airflow HDFS Provider (Apache Software Foundation) Fixed in 4.1.1
- Fix · GHSA-5hj9-m76g-xrc8 apache-airflow-providers-apache-hdfs (PyPI) Fixed in 4.1.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-41267
- 2026-10-03 Alias added: GHSA-5hj9-m76g-xrc8
References
Sources
- CVE-2023-41267 · CVE Program
- CVE-2023-41267 · NVD
- FIRST EPSS
- GHSA-5hj9-m76g-xrc8 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-41267 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences