A vulnerability exists on all versions of Ivanti Connect Secure below 22.6R2 where an…
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A vulnerability exists on all versions of Ivanti Connect Secure below 22.6R2 where an attacker with a foothold on an Ivanti Connect Secure (ICS) appliance can escalate their privileges by exploiting a vulnerable installed application. This vulnerability allows the attacker to gain elevated execution privileges on the affected system.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Ivanti | Connect Secure | 22.6.1 to before 22.6.1 | 22.6.1 | Patch available | CNA |
- Connect Secure VendorIvanti Affected 22.6.1 to before 22.6.1 Fixed in 22.6.1 Patch available CNA
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ivanti:connect_secure:22.1:r1:*:*:*:*:*:* | 22.1 r1 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:22.1:r6:*:*:*:*:*:* | 22.1 r6 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:22.2:-:*:*:*:*:*:* | 22.2 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:22.2:r1:*:*:*:*:*:* | 22.2 r1 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:22.3:r1:*:*:*:*:*:* | 22.3 r1 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:22.4:r1:*:*:*:*:*:* | 22.4 r1 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:22.4:r2.1:*:*:*:*:*:* | 22.4 r2.1 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:22.4:r2.2:*:*:*:*:*:* | 22.4 r2.2 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:22.5:r1.1:*:*:*:*:*:* | 22.5 r1.1 | Vulnerable | Ivanti |
| cpe:2.3:a:ivanti:connect_secure:22.5:r2.1:*:*:*:*:*:* | 22.5 r2.1 | Vulnerable | Ivanti |
- cpe:2.3:a:ivanti:connect_secure:22.1:r1:*:*:*:*:*:* Versions 22.1 r1 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:22.1:r6:*:*:*:*:*:* Versions 22.1 r6 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:22.2:-:*:*:*:*:*:* Versions 22.2 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:22.2:r1:*:*:*:*:*:* Versions 22.2 r1 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:22.3:r1:*:*:*:*:*:* Versions 22.3 r1 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:22.4:r1:*:*:*:*:*:* Versions 22.4 r1 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:22.4:r2.1:*:*:*:*:*:* Versions 22.4 r2.1 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:22.4:r2.2:*:*:*:*:*:* Versions 22.4 r2.2 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:22.5:r1.1:*:*:*:*:*:* Versions 22.5 r1.1 Vulnerable ·Ivanti
- cpe:2.3:a:ivanti:connect_secure:22.5:r2.1:*:*:*:*:*:* Versions 22.5 r2.1 Vulnerable ·Ivanti
Remediation
- Fix · CNA Connect Secure (Ivanti) Fixed in 22.6.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Ivanti Connect Secure 22.6.1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2023-22135 A vulnerability exists on all versions of Ivanti Connect Secure below 22.6R2 where an…Priority LOW 38
Timeline
- 2026-10-02 Threatist record created from CVE-2023-41720
- 2026-10-03 Alias added: GHSA-rphc-vh34-9jmw
References
More Ivanti Connect Secure vulnerabilities
- TI-2025-16349 Stack-based buffer overflow in Ivanti Connect Secure KEVCVSS 3.1CRITICAL 9.8
- TI-2021-05754 Improper authentication in Pulse Connect Secure KEVCVSS 3.1CRITICAL 10.0
- TI-2019-08600 In Pulse Secure Pulse Connect Secure (PCS) 8.2 before 8.2R12.1, 8.3 before 8.3R7.1, and… KEVCVSS 3.1CRITICAL 10.0
- TI-2025-00226 Stack-based buffer overflow in Ivanti Connect Secure KEVCVSS 3.1CRITICAL 9.0
- TI-2024-14549 Command injection in Ivanti ICS KEVCVSS 3.1CRITICAL 9.1
- TI-2021-05760 Command injection in Pulse Connect Secure KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2023-41720 · CVE Program
- CVE-2023-41720 · NVD
- FIRST EPSS
- GHSA-rphc-vh34-9jmw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences