Read the docs
TI-2023-22324 Aliases CVE-2023-41939GHSA-4gh2-m88h-8cj8

Jenkins SSH2 Easy Plugin 1.4 and earlier does not verify that permissions configured to…

Priority MEDIUM 41CWE-281Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.

Summary

Jenkins SSH2 Easy Plugin 1.4 and earlier does not verify that permissions configured to be granted are enabled, potentially allowing users formerly granted (typically optional permissions, like Overall/Manage) to access functionality they're no longer entitled to.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00665 52nd percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:ssh2easy (Maven): 1.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins SSH2 Easy Pluginup to 1.4—No fix listedCNA
—org.jenkins-ci.plugins:ssh2easy (Maven)before 1.61.6Patch availableGHSA-4gh2-m88h-8cj8
  • Jenkins SSH2 Easy Plugin VendorJenkins Affected up to 1.4 Fixed in — No fix listed CNA
  • org.jenkins-ci.plugins:ssh2easy (Maven) Vendor— Affected before 1.6 Fixed in 1.6 Patch available GHSA-4gh2-m88h-8cj8

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:ssh2_easy:*:*:*:*:*:jenkins:*:*up to 1.4VulnerableJenkins
  • cpe:2.3:a:jenkins:ssh2_easy:*:*:*:*:*:jenkins:*:* Versions up to 1.4 Vulnerable ·Jenkins

Remediation

  • Fix · GHSA-4gh2-m88h-8cj8 org.jenkins-ci.plugins:ssh2easy (Maven) Fixed in 1.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-41939
  2. 2026-10-03 Alias added: GHSA-4gh2-m88h-8cj8

References

Sources