A Cross Site Scripting vulnerability in Alkacon OpenCms before 16 exists via updateModelGroups.jsp.
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A Cross Site Scripting vulnerability in Alkacon OpenCms before 16 exists via updateModelGroups.jsp.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00149 4th percentileScored 2026-11-07
Fix Fixed org.opencms:opencms-core (Maven): 16.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.opencms:opencms-core (Maven) | before 16.0 | 16.0 | Patch available | GHSA-2887-f3v6-6rjf |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.opencms:opencms-core (Maven) Vendor— Affected before 16.0 Fixed in 16.0 Patch available GHSA-2887-f3v6-6rjf
Remediation
- Fix · GHSA-2887-f3v6-6rjf org.opencms:opencms-core (Maven) Fixed in 16.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-42345
- 2026-10-03 Alias added: GHSA-2887-f3v6-6rjf
References
Sources
- CVE-2023-42345 · CVE Program
- CVE-2023-42345 · NVD
- FIRST EPSS
- GHSA-2887-f3v6-6rjf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences